Google products suddenly uncooperative with Brave Shields Up?

I’ve been using Brave for several months with little issue. My organization uses Google products extensively and I haven’t had many problems other than a few very minor functional issues with spreadsheets etc.

Suddenly today, it seems Google may have made some changes that specificially interfere with using Shields Up on thier products.

If I go to Google Drive, I get a message saying “You are not signed in
You are signed out. Sign back in, then click ‘Retry’.” - Clicking the “Sign Back In” link just refreshes the error message and does not lead to a login option - Besides the fact that I’m not signed out in the first place. I can access specific documents and other account products.

Gmail has a message saying that my POP email account is having authentication issues and that I need to sign back in, and all my signature images are broken images.

All of this is fixed if I toggle to “Shields down” in Brave.
The weirdest part is that the Shields menu reports that there are 0 blocking of anything when activated.

I realize that this is all very likely an issue with Google changing things and probably not Brave malfunctioning, but I’m sure contacting Google support will not be helpful. :smile:
I just wanted to know if anyone else has this problem or if anyone has any input…
(except for “Stop using Google products.” or other like comments. I don’t need that sort of thing, thanks. :face_with_raised_eyebrow: )

@KingDingbat,
Thanks for reaching out.

Have you tried clearing your cache/site data for your Google account(s)? This may solve the issue you’re encountering. Visit gmail.com, drive.google.com, and any other associated apps, click the “lock” icon in the address bar, then Site settings --> Clear data.

Note that you’ll have to log back into the sites you’ve done this on but when you do the messages you’re seeing should not appear again.

Wow! What a fast response :stuck_out_tongue: - I’ll try that and report back, thanks!

Unfortunately, that does not seem to have worked. Thanks for the suggestion though.
I still have the issue, unless I disable Shields in Brave.

1 Like

@KingDingbat,
Thank you for testing – Going to try a few things on my end and see if I can get more information on this. Appreciate your patience.

1 Like

Another symptom:
forms.google.com does not load with Shields up. Disabling shields does fix it.

I find it really strange that Brave is not even reporting blocking any scripts or anything either. Its almost as if Google is sensing that Shields Up is on and pre-emptively just not loading anything.

Maybe try loading an extension or two, like Privacy Badger or uBlock Origin when dealing with Google sites?

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.