Google Meet effects stopped working

Description of the issue:
The Google Meet effect are not working anymore.

How can this issue be reproduced?

  1. Start a Google Meet meeting room
  2. Select effect
  3. Says to enable Hardware Acceleration, but it is already selected.

Expected result:
Should work and select any kind of effect… blur, background etc

Brave Version( check About Brave):

Additional Information:
It stopped working today, it always worked before

Hello @FabioMagnoni

Thanks for bringing this to our attention and sorry to hear you’re having trouble with Brave. Can you try these clearing the cookies on the site? To do this follow these instructions :

  1. Visit [site] and click the “lock” icon on the left side of the address bar
  2. Click Site Settings
  3. Scroll to the very bottom and click Reset Permissions
  4. Now scroll back to the top of the page and click the “back” arrow – this should land you in Content settings
  5. Go to Cookies --> See all cookies and site data
  6. Use the search box and run a search for [site]
  7. Click Remove All Shown to clear any remaining cookie data for the site.
  8. Relaunch Brave, visit and authenticate into [site].

If this does not work, you may want to try clearing all your browsing data.
You can clear any/all your data by going to Menu --> History --> Clear Browsing Data – ensure that the Cookies and Site Data box is checked.

Let me know if that fixed the issue and have a great day!

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.