Google Meet, Change Background Not Working


Description of the issue:
How can this issue be reproduced?

  1. Join a Google Meet
  2. Choose “Change background”
  3. Receive a message that says “Configure your browser for background effects. To use background effects, turn on hardware acceleration in your browser settings.”
  4. Checked the settings and hardware acceleration is already on in the browser settings.

Expected result:
Like when I am in Chrome, I would expect to be able to change my background.

Brave Version( check About Brave):
Version 1.26.67 Chromium: 91.0.4472.114 (Official Build) (64-bit)

Additional Information:
OS: Ubuntu 20.04.1 LTS (fossa-bulbasaur X39)
CPU: 11th Gen Intel® Core™ i7-1165G7 @ 2.80GHz × 8
Memory: 15.4 GiB
Graphics: Mesa Intel® Xe Graphics (TGL GT2)
GNOME: 3.36.8
Windowing System: X11 and Wayland both have the issue

1 Like

Hey @gwduvalljr !

Do you have any extensions installed? If so can you you try disabling them to see if it solves the issue?

Porridge

1 Like

Hit “send” too soon.

Thanks @GreenBananaPorridge. No extensions installed. Just plain-vanilla Brave.

1 Like

Can you try these clearing the cookies on the site? To do this follow these instructions :

  1. Visit [site] and click the “lock” icon on the left side of the address bar
  2. Click Site Settings
  3. Scroll to the very bottom and click Reset Permissions
  4. Now scroll back to the top of the page and click the “back” arrow – this should land you in Content settings
  5. Go to Cookies --> See all cookies and site data
  6. Use the search box and run a search for [site]
  7. Click Remove All Shown to clear any remaining cookie data for the site.
  8. Relaunch Brave, visit and authenticate into [site].

If this does not work, you may want to try clearing all your browsing data.
You can clear any/all your data by going to Menu --> History --> Clear Browsing Data – ensure that the Cookies and Site Data box is checked.

Thank you,

Porridge

1 Like

@GreenBananaPorridge No change in behavior. It also does not work in a “Private window” where there would be no cookies or scripts already loaded.

1 Like

Would you mind trying to create a new test profile (ensure you close the original profile window you had open), browse for a bit using it, and tell me if Brave behaves the same way when using it?

Thank you,

Porridge

1 Like

Actually, before creating a new profile, can you try turning off hardware acceleration to see if the problem persists?

Porridge

Turned it off in current profile. I got the same error message.

Created a new profile. Closed current profile. No matter the state of hardware acceleration, I get the same error.

Hey @gwduvalljr !

Is this a new issue or has Google Meet always had this issue?

Porridge

1 Like

@GreenBananaPorridge I have no idea. I only started trying to use a background about a day before I posted my question. During that day, I tried many things to get it to work and searched for any info before I posted my question.

1 Like

Can I ask you to try this on Chrome to see if you get the same problem? Also, please try the Nightly version of Brave to see if the issue persists. You can download it here → https://brave.com/download-nightly/

Thank you!

Porridge

1 Like

It does work in Chrome which is why I expected it to work in Brave. In fact, in my original post I used Chrome as the expectation.

I will try the nightly version, but it’ll be tomorrow or over the weekend before I can do it.

1 Like

Hey again @gwduvalljr !

Sorry for all the roundabout suggestions but I will say try to use Google Meet with Shields turned off (Click on the Brave logo in the address bar) on the actual Google Meet website.

Porridge

1 Like

I made sure Shields were down and I got the same message.

1 Like

Finally got a chance to try the nightly and it works.

So, I suppose at some point in the future the stable version of Brave will start to work?

CONGRATULATIONS ! We are happy for you when things are fine for you, let it be.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.