Google Maps zoom sensitivity (seems to be recurring theme over the years)

Description of the issue:

https://maps.google.com is unusable due to extremely high sensitivity of trackpad zoom gesture on MacOS 14.4.1.

How can this issue be reproduced?

  1. Navigate to maps.google.com
  2. Use an Apple Magic Trackpad two-finger up/down swipe to zoom in and out

Expected result:

As recently as yesterday, zooming was smooth and even, like in other Chromium-based browsers on MacOS. Today, each zoom level is a specific step, and each step zooms extremely fast, making it impossible to control.

Brave Version( check About Brave):

v1.65.126

Additional Information:

AFAIK I have not applied an update to Brave or my in at least 24 hours, nor have I changed settings in any way, and this began happening today.

According to this Github Issue from 4 years ago, this is related to Google serving the non GPU-accelerated version of Maps to Brave. I have confirmed that this is indeed the case. (I see “3D Earth View is unavailable” at the bottom of the Satellite view.). Testing with Shields Down did not correct the issue.

I’ve experienced this issue in the past in a prior Macbook, and IIRC the hardware acceleration setting fixed the problem. That is not the case now.

2 Likes

@cmenscher,
Thank you for reporting. I’ve reached out to our devs about this and we apparently have a general fix for this incoming. Waiting to hear more information but this [recurring] issue is known and being addressed.

This should be fixed now, let us know if you see any issues. You might have to restart the browser.

Still going on with me, I’ve been thinking it’s a problem with my mouse, as this overly sensitive, out-of-control zoom in & out, with Google Maps, happens on other browsers as well. It’s really out of hand. It reminds me of Santana talking about playing at Woodstock, and saying all those weird faces he was making while playing, were due to his tripping on some strong LSD, and imagining his guitar neck was like a snake, and he was doing all he could, to try and keep it under control!

All I have to do is even slightly move my mouse, and it blows up, or shrinks way down, shifts left or right, & is just generally unruly, and uncontrollable. Do you think it could be the mouse (Apple “magic mouse”)?

How a google map help us to fly a drone. For example: flying drone in Londonstrong text, how we know which places allows drone to be fly or not?

I had the same issue with the latest Brave release, and the problem was a feature of my VPN that will block web workers to run in the background, after that was disabled the zoom became smooth again, hope this works for you guys.

Still experiencing this.

  • Version 1.67.119 Chromium: 126.0.6478.114 (Official Build) (arm64)
  • MacOS Ventura 13.6.7 (22G720)

LE: I could fix by disabling ‘graphics acceleration’, browser wide Use graphics acceleration when available - as recommended here (back then, in 2022 it was called ‘Hardware acceleration’).
Would be nice if one could control graphics acceleration per site.

1 Like

@ubik
Thank you for the information. I’m going to ping some devs and make sure they know that this issue is still around and needs to be resolved.

Thank you

1 Like