Google Maps sidebar freezes

Have been experiencing this for a few weeks now. The side bar on Google Maps freezes —sometimes for almost a whole minute— when sliding up/down on the info of a specific location. I haven’t noticed the issue when sliding up/down on search results.

Version 0.70.123 Chromium: 78.0.3904.97 (Official Build) (64-bit)
MacOS 10.15.1
MacBook Air (13-inch, Early 2015)

1 Like

@vanyacrow,
Does the sidebar show issues immediately when you land on the site or does it eventually stop working? Also, can you tell me what you Shields settings are set to for maps.google.com?

@Mattches,

Here is a screenshot of the shields —pretty much all up but scripts:

The sidebar scrolls fine on the first scroll gesture. It freezes when trying to scroll up/down again. The freeze seems longer —I’d say 3 or 4 times— that first time than on following ones, which don’t seem to happen all the time.

Interesting – I’m not seeing the same behavior with the same settings. Using macOS Catalina, Brave v0.70.123:

Is there something specific you’re searching in the side bar? Or is it just scrolling up/down as I did in the video above?

As said on the first message, I don’t experience the problem either when scrolling the search results list, only when selecting an item in the list and scrolling through its info.

@vanyacrow,
Apologies for misreading. Ran another test to make sure I wasn’t getting the same behavior as you – still unable to reproduce:

Can you try disabling Hardware Acceleration to see if that makes a difference?

Settings --> Additional Settings --> System --> Hardware Acceleration

No worries, @Mattches, it’s easy to miss a bit of info with so many flying around :wink:

Just deactivated Hardware Acceleration and the issue persists; same behaviour as far as I can see…

P.S.— Try to upload a video capture, but it seems I’m too new in the community to be allowed uploads :confused:

@vanyacrow,
Sorry for the very late response – I just got back from some time off :slight_smile:

You might try changing the Device Recognition setting in the Shields panel to Allow all... if you’re still experiencing this issue.

Welcome back! :slight_smile:

Just tried allowing all device recognition, but the problem persists.

1 Like

@vanyacrow,
Thanks – glad to be back :slight_smile:
Have you tried clearing your cache/site data for maps.google.com? Use the lock icon in the address bar while on the site, then Site Settings --> Clear data

That didn’t help either :confused: But I noticed something else: the sidebar seem to un-stuck if move the cursor away so the grey slider position marker fades away; when I bring the cursor back over the sidebar, it works again.

@vanyacrow,
Can you try the same actions while using a Private browsing window?

Yep, the issue replicates in private browsing.

1 Like