Google maps location permission

Google maps isn’t working. Suspect I turned off location permission at some point. How do I allow https://www.google.com/maps location permission. Found the location section under settings but you don’t seem to be able to manually insert a URL. TIA

Description of the issue:
How can this issue be reproduced?

Expected result:

Brave Version( check About Brave):

Additional Information:

1 Like

@wiredgeorge,
Let’s get a fresh start on Maps and ensure that we set default permissions properly.
On maps.google.com, click the “lock” icon in the address bar - then click Site settings. On this page, click both Clear data and the Reset permissions buttons here. You will be prompted to refresh the page (maps.google.com) – do so.

After the refresh, you should be prompted to Allow maps the appropriate permissions.

1 Like

That did it . Thanks!

2 Likes

@wiredgeorge,
You’re very welcome – enjoy!

Hi, I’m having the same issue, but the suggested solution didn’t work.
All websites that have geolocation show me the same (wrong) location

@angelgc,
Do you have any extensions installed at this time? Also, can you tell me what your Shields settings are set to for the site?

Same extensions I used in Chrome. I’ve tried shields on and off, with the same outcome.

@angelgc,
Thank you, but can you please provide the information requested? What were your Shields settings configured to before turning them off and what extensions do you have installed at this time?

Hi @Mattches
This was the setting before turning off the shields (shields are currently off for Google Maps for example):



And I’ve disabled all my installed extensions:

The problem persists. Brave is the only browser showing this behaviour in the location services (I also use Chrome, Edge and Firefox).
My OS is Ubuntu 20.04

I have the same problem. Also Ubuntu 20.04 (interestingly). Chrome (Beta) works. Firefox works. Brave fails.

I’m glad Google can’t localize me.
Just my two cents.

Hello, this is marked as solution, but it’s been proven incorrect

@angelgc,
Can you please try creating a new temporary browser profile (ensure you close all other Brave windows except for the one new browser profile window) and tell me if you get the same results on Google maps?

Hi @Mattches
I just tried with a new browser profile, made sure that all other windows were closed, but the results are the same :frowning:

Can you install Brave beta @angelgc and re-test? no VPN installed?

1 Like

@fanboynz I just installed Beta. It shows the same wrong, arbitrary location, at ~23km from my actual location

1 Like

What does https://bestvpn.org/html5demos/geo/ show?

@fanboynz the same wrong location Google Maps (and every other location service) shows. Maybe I should find an appartment there and make it easier :joy:

When I tested https://bestvpn.org/html5demos/geo/ this in Chrome vs Brave, the difference was about 10-20meters (side-by-side). So basically the same area, within margin of error

In my case, there’s a 23km difference. Quite a lot
I still don’t get why it takes that random (always the same) location when I’m at home