Google Duo is not working in Brave

Description of the issue:
As of today, Google Duo throws an error in Brave: " We are sorry, but you do not have access to this service. Please log in to your Admin Console to enable this service." This application worked great yesterday.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
1, Attempt to log into Google Duo in Brave browser.

Actual Result (gifs and screenshots are welcome!):
In this image, Brave is on the left displaying the error. Chromium is on the right logged into Duo with the same account. (I am a Google Superadmin for our organization and have attempted Google’s troubleshooting and reading the last bug Brave report about Duo from June of '19 before posting here.)

Expected result:
The ability to log in and use Google Duo within Brave.

Reproduces how often:
100% of the time as of this morning. I had been using it daily without issue in Brave for about two weeks prior.

Operating System and Brave Version(See the About Brave page in the main menu):


Additional Information:
I have tried putting shields down for Duo and it did not work. I have also cleared the cache in both browsers to make sure Chromium wasn’t using an old access token. Note: I do have 2FA enabled for my Google account so I get a push notification on my phone for every new login (not sure if that makes a difference for Brave, but I only get the push notification in Brave if I try to log in from a ‘private’ window, though I’m still unable to log in.) I am still able to use Duo through other browsers and the phone app with my account.

1 Like

@Ernie_S,
I know it’s not an extension but I’m curious to see if toggling on Allow login for Google extensions in Settings --> Extensions changes the behavior at all?

Additionally, can you share a screenshot of the dev tools [Console] tab when you see that error?

So, allowing login for Google extensions did not work. I was able to grab a screenshot of the error that flashes in the console when the page loads, but I am not fast enough to expand the tree for more detail, sorry. I will keep trying and update here if I get a better look at the error:
Duo Error
(This screenshot was taken with the login for Google extensions setting on)

I was also able to grab this error on the 3rd attempt:
Duo error2

And this one from the login page of Duo:
Duo login page error

I’m also having the same error message, however i do not have any additional technical information. just need assistance and possible solutions.

Troubleshooting and verifications I tried were:

  1. Verifying Duo works in other browsers
  2. Checking settings for updates
  3. Deleting old cookie
  4. Making sure I had the latest Brave update
  5. Restarting/launching both browser and computer

Btw, I’m running an Mac OS

Please advise & thanks in advance

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.