Google Docs will not load

I can’t get Google Docs to load on Brave and I’m tired of having to go back to Firefox to use it. Anyone know a fix? This is a screen shot of what I have.

Does disabling Brave Shields via the Brave Shields icon in the address bar resolve the issue?

It does not, but thank you. Any other suggestions?

Are you using any extensions? If you do, disable them to check if it’s related to them.

Nope, no extensions.

Try the following:

  1. Open Google Docs.
  2. Click on the padlock icon in the address bar.
  3. Site settingsClear dataReset permissions.
  4. Open brave://settings/clearBrowserData via the address bar.
  5. Time rangeAll time.
  6. Select Cached images and filesClear data.

Did all of this, still no go.


Check whether the issue persists in a fresh user profile, we would like to determine whether the issue is related to your current user profile in some way.

Okay, so a new profile worked. I wonder what the problem is with my current one, then. Thanks for your help though, really.

You could try the following for your original user profile:

  1. Open brave://settings/clearBrowserData via the address bar.
  2. Click on AdvancedTime rangeAll time.
  3. Select Cookies and other site data, Cached images and files, Site and Shields Settings.
  4. Clear data.

Clearing Site and Shields Settings resets global Brave Shields settings, re-adjust them via brave://shields if needed.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.