Google Docs not rendedring break lines on RPM 1.43.93 version

Description of the issue: On Google Docs and Google Calc the line break at the end of the document/cell functionality is not working (see the screenshot). I have tried multiples documents and it is always the same on Brave (other browsers are rendering the files correctly). Also, the blinking cursor is always stuck at the beginning of the line instead of pointing to the places where the letters are going to appear.

Exact URL of the website in question: https://docs.google.com/document/*

Does the site function as expected when Shields are turned off? No, also not working

Does the site work as expected when using Chrome? No, is working fine on Chrome and Firefox

Brave version: 1.43.93

SO: Fedora 36 (tried on 2 different PCs with the same OS and Brave downloaded as RPM from Brave website)

Screenshot:

1 Like

I have the same issue on macos.

In addition it seems that style change within a paragraph triggers carriage return (but no line feed) so that text gets rendered over other text

Text on one line, safari vs brave:
Screenshot 2022-09-22 at 9.53.07

With an extra newline added just before the first style change, safari vs brave:
Screenshot 2022-09-22 at 9.53.29