Google Auth: Unable to login even though I allowed the Google Auth permission

Description of the issue: When I login with my Google Account on another pop-up page, the authentication and the redirect process didn’t push through for some reason. It only gets stucked on the login page.

Steps to Reproduce (add as many as necessary):

  1. Visit
  2. Click “Login”
  3. Click “Google”
  4. A Google auth pop-up will appear and will let you login with your Google Account.
  5. Grant the permission request from the Lazada Firebase Production
  6. The redirection didn’t push through, it’s just stucked on the Login Page

Actual Result (gifs and screenshots are welcome!):
The success redirection didn’t push through, causing the site to get stucked on the login page and wasn’t able to login

Expected result:
The authentication must succeed and the user must be redirected to the home page and indicate that he/she is logged-in to the site.

Reproduces how often:
Tried it multiple times, I even tried disabling the blocker feature on that particular page, but it didn’t work.

Operating System and Brave Version:
Windows 10 Pro, Brave Version 0.68.139 Chromium: 77.0.3865.90 (Official Build) (64-bit)

Additional Information:
I think the browser is blocking a script that lets the auth and the redirection process happen.

Maybe related to another issue, similar google-auth issues

Hi @fanboynz, just an update. I visited the opened issue on your Github repo and you’re right, allowing the cookies on the browser’s settings solved the issue and my auth was able to push through.

I guess that would be a workaround fix for now. I hope it gets fixed on the future updates. Thanks :slight_smile:

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.