Google Assistant Is Not Working Properly in Brave


#1

Hi Brave Team,

I noticed that Google Assistant will not activate while in Brave. It will work in every other application I have, even Chrome 60/61/62. It seems to me that the overlay is being blocked by Brave. I’ve tried activating assistant both by holding the home button down and using active edge.

To reproduce: Any phone with Android 8.0, open Brave and try to launch Google assistant. Let me know if you have other questions.

What I tested on:
Brave 1.0.35 [arm64 version if there is one]
Google Pixel 2
Android 8.0
September 5, 2017 - Security patch
Kernel version 4.4.56


#2

well the essence of brave is to protect your privacy and assistants scavenge your for phone for your data. the reason its not working with brave is that the shield blocks it from collecting data of your internet usage.


#3

I like the idea, but is this really by design? If so maybe it is toggle worthy? Toggling the shield does not seem to resolve the issue. For power users of Google Assistant, it is a pretty core feature, especially in your browser.


#4

I agree with the Bug Reporter. It would be useful to be able to activate/trigger the Google Assistant/Active Edge when the Brave browser is the active app. I’ve tried to disable the Shield and Google Assistant/Active Edge still doesn’t come on when triggered within the Brave app.


#5

I have the same problem with Brave and it is the main reason I have stopped using Brave. Google assistant is built into the Pixel 2 XL phone I’m using so it should work properly like it does on every other app.


#6

Hi @BugReporting @trailrunner76 @Bwhite116,

I’m sorry for late responses and thanks for reporting. :slight_smile:
I added your comment as +1 and this issue is logged here
https://github.com/brave/browser-android-tabs/issues/459

Thanks,
:slight_smile:


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.