Google account sign-in every time I open Brave

Description of the issue: Every time I open Brave and click on the address bar, it redirects me to Google sign-in page. The problem started after I cleared my history, cookies and cache which I do pretty often but after this one time the problem remains. I have already been logged into my Google account and skipping the sign in process does not change anything.

Steps to Reproduce: Opening Brave browser.

Actual Result:

Expected result: The homepage does not redirect me to the Google sign-in page when I click on the address bar.

Reproduces how often: Every time.

Operating System and Brave Version:
Operating system-
Windows 10 Home.
Brave version-
Version 1.24.85 Chromium: 90.0.4430.212 (Official Build) (64-bit)

Additional Information: I have been using Brave since a long time as my default browser on Windows and Android since a long time and till now I have not had any problems. I hope this problem gets solved as soon as possible. Thank you.

3 Likes

@iliyan_sharif,
Thank you for reaching out to us.
I’m a little unclear on the behavior here – you’re saying that simply clicking in the address bar redirects you to a Google login page? That is, on click, you’re redirected? Or is it when you click and attempt to visit a site? Or is it when you click and try to visit a specific site?

Thanks for the prompt reply.
Yes I get redirected to the sign in page as soon as I open the browser and click the address bar. I have no clue why this is happening.
I guess I should reinstall Brave and hopefully the issue gets addressed.

1 Like

@iliyan_sharif,
A reinstall would probably work – but before you do, I would try creating a new temp browsing profile and test to see if you get the same behavior when using that profile.

1 Like

This exact same thing occurs every time I open Brave, but I have a couple of start pages. One of the start pages is gmail and I’m already logged in.

2 Likes

Same happening to me. I use the option to open the pages I had open when I close. When I open Brave, any Google pages I had are still logged in, but it opens a new page to sign into my Google Account.
I tried to change it to open specific pages ore just the new tab page, but it still happens, as soon as I open Brave, it opens a new page to sign into Google, eve though I already am.

2 Likes

Okay so I reinstalled Brave and the problem still persists.

1 Like

Hey iliyan_sharif,

Did you also try doing this in a new profile, like Mattches suggested?

Update: I removed from Brave all extensions related to Google (Keep, Translate, save to Drive, etc.). This seems to have solved the problem.
I believe the source of the problem is related to Google login to extensions. I haven’t tested these extensions individually to see if they all cause the problem or if it’s just one or a few of them, but I’d assume it’s ever extension that requires a Google Account.
This is corroborated by the fact that creating a new Brave profile or reinstalling the browser does not solve the problem if the extensions are installed, but as soon as they are removed the problem stops.

For now, not having Brave opening a Google sign in page is reason enough for me to remove these extensions and use their respective webpages, but I doubt most people would feel the same way.

4 Likes

@PedroPV,
Thank you for reporting – I’ll inform the team of this and see if this something that changed on our end or if this is a Google/extension issue.

3 Likes

I disabled the google-keep extension & restarted, and that fixed this issue.
Google Keep Chrome Extension
enabling & logging in, then disabling again, then enabling triggers the google login.

UPDATE: FWIW, I added this to Chrome and restarted and chrome did not prompt for a google login.

1 Like

Yep that did it. Removed the Keep extension and it’s great now. Thanks.

2 Likes

i’m still getting this behavior.
on macOS
Version 1.25.68 Chromium: 91.0.4472.77 (Official Build) (x86_64)
i tried disabling/reenabling the ‘allow google login for extensions’ and also uninstalling/reinstalling the google keep extension.
still get the sign-in prompt on the extension, and every attempt to sign in does nothing.

I never reinstalled the extension as it wasn’t of much use to me.
If you want to keep the extension, just click on the sign-in option that’s in the screenshot you attached. Disable Brave shields on the sign-in page and fill your login info. This should solve your problem.

sadly, this process does not work.
same results.
i disabled brave shields on https://accounts.google.com/ and signed in, but the extension still prompts for login.

2 Likes

Disabling Keep extension worked for me!
Thanks @PedroPV @jarreed @iliyan_sharif

3 Likes

The Google Keep extension is what’s causing the prompt for password, disabling or removing the Keep extension fixes the issue. I no longer have the Keep extension in Brave.

FWIW the Keep extension dev doesn’t seem to care if the extension works on anything but Chrome.