Godoc Header Links don't link correctly in a new tab

I realize this might be very specific but when looking at any godoc (Go programming language documentation) when you click on a section header it correctly links within the same tab. If I select a section header to open in a new tab the URL is correct but the browser goes to a random spot on the page.

Steps to reproduce:

  • Go to any godoc page (use this for example)
  • Click on any header link in the index within the same tab and it should link correctly to that section
  • Right click on the same header and select Open Link In New Tab and it will have the correct URL in the address bar but be on a random place in the page.

It does seem to work if copy the URL manually from any tab and manually open a new tab and enter the URL it goes to the correct section. Seems to be an issue when auto opening the tab via the Open Link In New Tab option in the right click menu.

This is…strange.Works fine on my Dev version of Brave but I can reproduce the error your’re having on the currently live build. I’m going to see what I can dig up about this, in the meantime would you be able o provide your about:brave information?

Sorry forgot to include that here it is:

Brave: 0.23.105
V8: 6.8.275.24
rev: 9a46f8f5cb22a9daf2af21989aed25911aa6f839
Muon: 8.0.9
OS Release: 17.7.0
Update Channel: Release
OS Architecture: x64
OS Platform: macOS
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 68.0.3440.84

Just wanted to check back in see if any progress has been made on finding the issue. I’ve see a few updates of Brave but the issue still persists.

Here’s my current about:brave:

Brave: 0.24.0
V8: 6.9.427.23
rev: f657f15bf7e0e0c50a2b854c6b05edb59bfc556c
Muon: 8.1.6
OS Release: 17.7.0
Update Channel: Release
OS Architecture: x64
OS Platform: macOS
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 69.0.3497.100

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.