Gmail Smart Reply "hidden-on-load"

Description of the issue:
I have Smart Replies activated in Gmail. On Chrome it successfully shows the smart reply UI buttons. When I load the same email in Brave it shows the smart reply UI buttons for a few milliseconds before they are being hidden.
If I remember correctly, this worked in a previous version of Brave.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Activate Smart Replies
  2. Open an email that you received from someone in Chrome/Firefox/Safari or another browser alternative.
  3. Check if the Smart Reply UI buttons are activated for this email (hint: not every email can be “smart replied”, so you might have to find an email that is valid for smart replies, or alternatively send yourself some simple email with a question inside from another email address to provoke the smart reply feature.

Actual Result (gifs and screenshots are welcome!):
Email opened in Brave:
Screenshot 2022-05-27 at 09.08.34

Expected result:
Email opened in Chrome:
Screenshot 2022-05-27 at 09.08.23

Reproduces how often:
Everytime

Operating System and Brave Version(See the About Brave page in the main menu):
Brave Version: V1.39.111
macOS: 12.3.1

Additional Information:

@chrisgraf

Lots of info, follows; use what you think you need . . .

Tip: Signed In to Google’s One Google Account, means that you are Signed In for all:

One_Google_Account_for_Everything

For access to G-mail via webmail (using Brave Browser) . . .

All of the following steps, assume that you normally wish to have / leave Brave Browser > Shields: UP

Including the Global Shields Settings:

In a Brave Browser - New Window, go to: brave://settings/shields

  • Enable: Show the number of blocked items on the Shields icon

If ‘Default view’ option is available, select: Advanced view

  • Disable: Auto-redirect AMP pages (AMP - Google’s Accelerated Mobile Page)
  • (Alternate setting for older Brave Browser versions, try: Disable Enable De-AMP at brave://flags)
  • Enable: Prevent sites from fingerprinting me based on my language preferences
  • Trackers & ads blocking: Aggressive
  • Enable: Upgrade connections to HTTPS
  • Enable: Block scripts
  • Block fingerprinting (aka Fingerprinting blocking): Strict, may break sites
  • Block cookies (aka Cookie blocking): Only cross-site

Recommended Brave Shields version is v1

In a Brave Browser - New Window, go to: brave://flags

Search for: Enable Brave Shields

  • DISABLE: Enable Brave Shields v2
  • ENABLE: Enable Brave Shields v1

Using site-specific Shields (v1) panels:

Brave Help Center not long ago, had site-specific Shields (v1) guidance and illustrations (that you see, immediately above), but now has site-specific Shields (v2):

https://support.brave.com/hc/en-us/articles/360023646212-How-do-I-configure-global-and-site-specific-Shields-settings-

Recommended in order to reduce influence by websites:

In a Brave Browser - New Window, go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

Recommended, go to: brave://settings/cookies

  • Enable: Block third-party cookies
  • Disable: Clear cookies and site data when you close all windows
  • Do not use: Sites that clear cookies when you close them (better to clear those cookie sites/sources, manually: brave://settings/clearBrowserData)

Recommended, go to: brave://settings/clearBrowserData

For tab Advanced - set:

  • Time range:All time
  • Enable: Browsing history
  • Enable: Download history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files
  • Disable: Passwords and other sign-in data (When Enabled DELETES PASSWORDS)
  • Disable: Autofill form data
  • Disable: Site and Shields Settings
  • Enable: Hosted app data

Click on the “Clear data” button.

(The “Clear data” button also saves the selections.)

Return to: brave://settings/clearBrowserData

For tab On exit - set:

  • Enable: Browsing history
  • Enable: Download history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files
  • Disable: Passwords and other sign-in data (When Enabled DELETES PASSWORDS)
  • Disable: Autofill form data
  • Disable: Site and Shields Settings
  • Enable: Hosted app data

Click on the “Save” button.

Return to: brave://settings/clearBrowserData

For tab Basic - set:

  • Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files

Click on the “Clear data” button.

(The “Clear data” button also saves the selections.)

In a Brave Browser > New Window, go to: brave://settings/cookies

Scroll down that settings page, to Sites that can always use cookies

Click the Add button

Enter accounts.google.com:443 as the site . . . but Do Not Enable

  • Current Private session only
  • Including third-party cookies on this site

Click the Add button

Repeat those steps for the following entries:

  • [*.]firebaseapp.com:443
  • [*.]google.com:443
  • accounts.youtube.com:443
  • docs.google.com:443
  • gmail.com:443
  • mail.google.com:443
  • www.gmail.com:443
  • www.google.com:443
  • www.gstatic.com:443
  • www.youtube.com:443
  • youtube.com:443

Next, go to brave://settings/content/javascript

Scroll down that javascript settings page to Allowed to use javascript

Click the Add button

Enter accounts.google.com:443 as the site . . . but do not Enable

  • Current Private session only

Click the Add button

Repeat those steps for the following entries:

  • accounts.youtube.com:443
  • apps.google.com:443
  • docs.google.com:443
  • meet.google.com:443
  • play.google.com:443
  • workspace.google.com:443
  • www.google.com:443
  • www.gstatic.com:443
  • www.youtube.com:443