Gmail notifications don't show up in Windows 10 Action Center

Description of the issue:
Gmail notifications don’t show up in Windows 10 Action Center

Steps to Reproduce (add as many as necessary): 1. 2. 3.
N/A

Actual Result (gifs and screenshots are welcome!):
See issue desc.

Expected result:
Action center would notify me of new emails received

Reproduces how often:
Every time a new email comes in

Operating System and Brave Version(See the About Brave page in the main menu):
image

Brave is up to date

Version 0.70.122 Chromium: 78.0.3904.87 (Official Build) (64-bit)

Additional Information:

Same issue here. It makes notifications nearly useless as they vanish for me after 5 seconds and there is no trace of them in the Action Center. Will have to switch browsers again if this can’t be fixed soon.

@Ziflin,
Are you both certain that your Focus Assist settings are configured properly? I’m able to receive push notifications from Gmail, as well as several other sites (including Community) without issue.

@Mattches, I don’t even know what my Focus Assist settings are. Let me look into that. Thanks so much. I was wondering why I haven’t heard anything on this. Thanks so much!

@Mattches

Mine appear to be set correctly. My settings say all apps will send the notifications. Let me know if I should change anything.

Here is a snip of my Focus Assist:

.

1 Like

@Mattches any input on this. It’s been sitting for 6 weeks or so?

@joshm65,
Can you confirm for me that you’re using the latest release of the browser? Should be v1.1.21 at the time of writing this.

Are you able to receive other desktop/push notifications for other sites? Would you be willing to test using this website?
https://web-push-book.gauntface.com/demos/notification-examples/
Note that when you land on the page, you’ll be prompted whether or not to Allow notifications from the site – this may seem obvious but make sure you do select Allow when you see the prompt. Then click on the example notification and see if you receive the push notification as intended.

Yes

Yes

Didn’t get the initial Action Center “this is where you’ll receive notifications” message but did get the following notification, seen in snip on left hand side, lower right corner (apologies on the dual screen-shot), in Action Center from the web-push-book site.

I get the “Allow” question for Gmail and Google Calendar. I always answer yes. When I do so for Google Calendar I then get a notification in Action Center, roughly paraphrased “This is where you’ll receive the calendar notifications”.

When I click "Allow for Gmail, nothing happens.

@joshm65,
Interesting – thank you for the details.
I have a couple of suggestions to try:

  1. First, can you try clearing your cache/site data for Gmail (note that you’ll have to re-authenticate into gmail afterwards), relaunch the browser and see if you’re prompted to allow (and subsequently receive) gmail notifications afterwards? To do this, go to gmail, click on the “lock” icon, then Site settings --> Clear data and also elect to Reset permissions for the site as well.
  2. If the above yields no results, can you try either disabling your browser extensions – or, creating a new browser profile (which will launch a new instance of Brave without any browsing data or extensions enabled), login to Gmail and see if you can illicit push notifications on this new profile?

This is done automatically every time I close Brave, so many times a day. I will check out the reset permissions item as I’m not familiar with that.

I will also do your # 2 and report back.

1 Like

I don’t see a reset button for permissions. Are you saying to delete the handlers in seen in snip?

Don’t see the reset anywhere on the above settings page.

Made a new user, logged in didn’t get asked about notifications. As you can see in the snip, there are no extensions loaded for this new user.

@Mattches
This isn’t worth going down a rabbit hole on… for me. I appreciate your suggestions, but it doesn’t seem like a simple fix.

I can live without these notifications.

Thanks so much!

I apologize for any confusion – it seems as though you’re looking in the Handlers section of the site settings – the page you’re looking for should have all site settings for gmail.
Before we get to that, I’d like to note that I did find an open issue that I If you’d like to try one more(for some reason) believed to be already resolved but it seems that it’s still being worked on:


So the cause of the above linked issue could very well be what you’re encountering. I’ll add your report to the GH thread on your behalf, as well as make some noise internally about getting this resolved, as the issue itself is quite old at this point.

Just for future reference, you can find the options I described in my previous post by doing the following (note that my example is on Community but the process and options is the same):

  1. Click “lock” icon

  2. Then Site Settings

  3. You should now be on this page, where you should see:

Reset correct settings as detailed above to no avail.

Had a look at the Git; from my read there was not a solution there. (Which may be you last point, about this being a legacy issue; not just the duration from when I posted)

Cheers @Mattches

1 Like

@joshm65,
Correct – it seems the issue has not yet been resolve. I’ve made some noise internally to see if we can get some dev eyes on the issue.

Got it. Keep me posted. I’ll live… :grinning:

My experience was consistent with the YouTube description, no sound or response from the system after engaging “Allow”.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.