Gmail: 2FA authentication not working when shield is up

windows

#1

Hi everyone,

I just noticed a problem when I tried loging into my gmail account. I’m using 2FA authentication with an app on my smartphone. The app asks if I’m loging in myself, I tap ‘yes’ and the loging is confirmed.
The problem in the Brave browser only shows up when the shield is up. When gmail sends a request to my phone, it directly opens a pop up asking if I want to try again or try another method. When I confirm the request on my phone, it does not log in but sticks to the screen it is on at that moment. It does not matter how many times I try it.

Steps to reproduce:

  • Activate 2FA authentication in gmail, use the mobile app.
  • Have the shield in the brave browser up
  • Login to gmail on your pc, in the brave browser
  • Accept the verification on your phone
  • Login is not possible

Workaround:

  • When the pop-up appears asking if you want to try again, deactivate Brave’s shield
  • Press ‘Try again’
  • Accept the request on the phone again
  • Activate Brave’s shield again

I’m using Brave (version 0.15.314) on windows 10:

Brave: 0.15.314
rev: 75ffa36130b1ad33c6f311e5e16ed7838b0b50a0
Muon: 3.0.202
libchromiumcontent: 58.0.3029.110
V8: 5.8.283.38
Node.js: 7.9.0
Update Channel: dev
os.platform: win32
os.release: 10.0.14393
os.arch: x64

Is someone experiencing this problem too, or does someone have a solution for it that does not involve deactivating Brave’s shield?


Google Prompt failure
#2

Issue has been reported and is being tracked here


#3