Global shields default not working on Tor window


Description of the issue:

I’ve changed the “Brave shields defaults” and turned on “Script blocking”. It’s working perfectly in “normal” windows, but it doesn’t works in Tor windows. When I visit a website using the “normal” window and click at Brave icon I can see “Scripts blocked”, but when I visit the same website using the Tor window and click at Brave icon, it shows me “All scripts allowed”. Keeping in the same Tor window I opened the Settings and it shows me (on the Brave shields defaults section) that “Script blocking” is enabled.

Actual Result:

Script blocking isn’t working on Tor window.

Expected result:

Global shields default working on all type of section (normal, incognito or Tor).

Reproduces how often:


Brave Version:

Version 0.60.48 Chromium: 72.0.3626.121 (Official Build) (64-bit)

Reproducible on current live release (yes/no):



closed #2

This topic was automatically closed after 30 days. New replies are no longer allowed.