Getting Windows 10 to allow Brave to be default browser


#1

Have Seen several Closed threads on this one…trying to get Windows 10 to make Brave the default browser…it does not provide Brave as an option in Settings and “App Store” goes nowhere for Brave (browser). Appreciate help. Thanks.


#2

Hi @GalwayIrish,

Did setting this via Preferences/Settings > General can help? The option is at the bottom of page.
Also cc-ing @sriram in case he can help.

Best,
:slight_smile:


#3

For windows you need to set it as default app in Windows settings


#4

Folks,

Thanks for feedback. The issue is when I go to Settings, the only options that come up for “browser” are Edge, Chrome, Explorer or “App Store.” No matter how I try, I can’t get Brave to display as an option. (The Brave browser is working fine; but I can’t find any way to get it to show as a Default option). Am I missing something here?

Thanks.


#5

This is the exact problem I’ve been having. I can set Edge or Chome to be default, but both are very buggy. I want to choose Brave, but it’s not an option.


#6

@GalwayIrish Could you try the step mentioned in this post Windows 10 - Default browser and html viewer setting issues ?


#7

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.