FVD Speed Dial Welcome Splash Screen

I have FVD Speed Dial and have been using it for years on Brave and other browsers. Works great, no issues. Normally, when I open a new tab, FVD Speed Dial comes up and I choose what saved link I want to go to. Today, when I opened a new tab, FVD came up, but a FVD Welcome Splash Screen came up too. Problem is, the Welcome screen appears EVERY TIME I open up a new tab. I can close the splash screen and use all Speed Dial links, but having to X out the Welcome Splash Screen every time I open a new tab is most annoying. NOTE: I have FVD on other browsers as well - FF, Edge, Chrome - and the splash screen does not appear on any of those browsers. Did Brave do something overnight to cause this? Solutions? Thanks!

5 Likes

Just an update - I said in my first post that my other browsers did not have the issue. Well, that seems to have changed as my other browsers not have the splash screen, so am guessing it is a FVD issue

3 Likes

I’ve got the same issue. Rather annoying to have to close the “Welcome to FVD Speed Dial Quik Tour!” window each time I open a new tab. Hopefully this gets fixed quickly.

3 Likes

SAME problem! REALLY ANNOYING! CAN YOU PLEASE FIX IT!??

2 Likes

Chrome user, same issue. Hoping it can be fixed asap!

1 Like

same issue here, welcome screen every time i open a tab or browser page… :frowning:

1 Like

Chrome user on multiple computer. Same issue.

1 Like

Same here, long time user, will give it a day or two before finding a different extension.

1 Like

I have the problem since yesteday, wensday 18 nov.

2 Likes

I have the same issue, just started. Every time, the Welcome Message pops up and it’s driving me crazy. FVD Speed Dial has been used by me for YEARS. I can’t even go through the Welcome Message Intro and have it go away. It comes back every time, every tab. PLEASE MAKE IT STOP!!
I’m using Chrome Version 87.0.4280.66 (Official Build) (64-bit) on Windows 10 Pro

2 Likes

Same issue
Chrome Version 86.0.4240.198 (Official Build) (64-bit)
Please fix this

1 Like

I have the same problem, too. Super annoying. And I’m using Mac Chrome.