Future updates, hmm so much

To get future Brave updates, you’ll need macOS 10.15 or later. This computer is using macOS 10.14.
I could care less about your updates(good one on the VPN and firewall)

Just like i said before, you guys hopped on GOOGLE and NSA.
Its not good.
Admin read this!! i advise you.
SDKs are not a sufficient answer because you can compile Brave on old sdks.

If you want to keep using Brave you can install an older version — but no, you will not receive additional updates beyond that version. This is a common practice for just about all available software (if you disagree, please try and run any modern browser on Windows 2000):