Forums.att.com - request entity too large

Description of the issue:
When I go to forums.att.com on my Win10 desktop with Brave, I get this error:

Request Entity Too Large

The requested resource
/cng/
does not allow request data with GET requests, or the amount of data provided in the request exceeds the capacity limit.

This error does not occur when I go to this site via Internet Explorer on my laptop. It also doesn’t occur on the ios version of Brave.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

See above, just go to forums.att.com

Actual Result (gifs and screenshots are welcome!):
See error above

Expected result:
Seeing AT&T Community forums page.

Reproduces how often:
Every time

Operating System and Brave Version(See the About Brave page in the main menu):
Version 0.67.124 Chromium: 76.0.3809.100 (Official Build) (64-bit)
Win 10

Additional Information:

@joshi apologies for late response.

Did you see same issue when you visit using other browser?

Did some browsing in Brave-release; It seemed to work okay here.

It’s worked fine in IE all along. And… for some reason today it is working ok in Brave. I didn’t do anything different than a few days ago, at which point it worked in IE but not in Brave.

If you try in Private mode, does it do the same thing? or how about disabling sheilds?