ForkDelta doesn't recognize that MetaMask is logged in

Description of the issue:
Even though I have logged in on Meta Mask when I open the ForkDelta comes a message saying: ‘You are using MetaMask but you are not logged in. Please log in to MetaMask and refresh.’

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Add MetaMask extention
  2. Log in to MetaMask
  3. Open ForkDelta: https://forkdelta.id/
  4. See the message

Actual Result (gifs and screenshots are welcome!):

Expected result:
I hope ForkDelta recognize that MetaMask is already logged in to synchronize the account automatically.

Reproduces how often:
Everytime I reload FrokDelta.

Operating System and Brave Version(See the About Brave page in the main menu):
Windows 8
Version 0.64.77 Chromium: 74.0.3729.169 (Official Build) (64-bit)

Additional Information:

@mahendra,
Can you try opening your Shields panel try setting 3rd party cookies option to Allow all?

Still the same…
all%20cookies%20allowed

@mahendra,
Forkdelta displays the “Connection Request” notification on my end:
image

Can you navigate to Menu --> More Tools --> Extensions --> MetaMask --> Details and in the Site access section, ensure that the MetaMask extension is allowed on all sites?

@Mattches Yes it was already.

@mahendra,
Would you mind sharing the console output as well for the site?

@Mattches Absolutely not. How can I do to share the console output for the site?

@mahendra,
My bad, I thought should’ve included instructions – please try the following:

  1. Ensure you’re logged into the Metamask extension
  2. In Brave, go to Menu --> More tools --> Developer tools --> [Console] to display the console output view.
  3. Visit ForkDelta and wait for the site connection request to appear (or throw the error, in your case) – you should see data populate the console
  4. Take a quick screenshot of the output displayed in the console window and drop it in your reply here (note that you can save and upload images on community using the Upload tool in the post editor OR you can simply copy and paste images into the editor directly)

here it is.

This topic was automatically closed after 30 days. New replies are no longer allowed.