Forgot Brave iOS App Passcode

Description of the issue:

I forgot my Brave app passcode and accidentally locked myself out of the app. I’ve tried deleting and reinstalling, deleting the iCloud backups file and reinstalling, and even resetting my phone settings and reinstalling (which shouldn’t even do anything, so I’m not sure why I did it).

I would greatly appreciate any help on how I can use the app again. Thanks in advance.

How can this issue be reproduced?

  1. Set an app passcode in the Brave settings
  2. Have the memory capacity of a goldfish
  3. Forget passcode and get locked out

Expected result:

Being able to delete the app and all its data, reinstall and be able to use the app normally again

Brave Version( check About Brave):

1.24

Mobile Device details

iPhone 12, iOS 14.5 Beta 8

Additional Information:

N/A

Yes, can someone please respond with help. Privacy shouldn’t be hard.

Yeah, still haven’t been able to get in.

Have the same problem here👋🏼
Only I didn’t set up a passcode for Brave browser, one day it suddenly locked on my iPad, but not for the other platform, tried re-install and any passcode I could possibly use but keep failing.

I have a similar issue. Using iPad. I don’t remember what the passcode is - I’ve been using the fingerprint scanner for access. Don’t know why, but the fingerprint stopped working for Brave and now I’m prompted for the unknown passcode as soon as I tap on the App. I have tried removing and reinstalling Brave, but nothing changes. I currently can not use Brave on my iPad. Frustrating. As another poster said: privacy shouldn’t be this hard. Please respond.

1 Like

I’d be lying if I didn’t take exception to the attitude of people in this thread.

‘Respond’ - Vast majority of us are not paid to respond to your every beckon call, it is a community, and if people can help, they will, when they are able to.

‘Privacy shouldn’t be this hard’. - You set security details, didn’t back them up, and forgot them. That isn’t hard either is it, but you still did it. You cant expect strict security then also expect to just walk back in when you mess up.

So lets take the self entitlement down a level. Patience is a virtue, or it was.

With that said, have any of you tried removing the app, deleting your icloud backup, then reinstalling it ?

1 Like

Hello, I have the same problem. Re-downloaded Brave after not using it for a while and was met with a passcode prompt I couldn’t get past.

  • Deleting the app and reinstalling does nothing.
  • Deleting the app, deleting icloud data (I think), and reinstalling does nothing.

Not sure where this data is stored. Is there something I’m missing? Thanks.

Yeah, I know everyone’s volunteering, I fully agree with you. I don’t just assume anyone has to help.
Also… I do blame myself for forgetting the code, but that doesn’t really explain why I can’t reinstall and use it.

And, yes, I did try those instructions at the end already. Thanks

Yeah, I tried those as well. I tried to do some digging but there’s only so much I can dig up on iOS and I’m a bit too dumb to understand Brave’s source code.

I have never received my brave app code.?

Brave doesn’t come with a presetcode”, in settings you have the option to set a passcode that will be required to be entered upon opening the app, you can also set up a fingerprint. However I have heard people saying it turned on automatically, this is not possible and I believe they accidently set it up or had a friend do it for them

Hi @jumpingwhale, this is a known issue we’re working to fix.
Please see:

1 Like

Hey, just wanted to let you know that we fixed this,
in next build, 1.26 you should be able to use Brave after reinstall

4 Likes