Force others langage

Leo seems to be very impressive. But it’s a pity that it only answers in English.

It sometimes accepts to answer in French, for example “Résume cette page en français”, but sometimes no…

Language models are theatrically OK to answer in French. It could be nice to be able to add conditions or to have tips to force language use.

Anyway, thanks to propose Leo!

Hi there,

Thank you for sharing! Just to confirm is your language settings to French?

I have the same problem, and I my Brave is set to French and to translate English in French

Same thing here.
My Brave was in French, but in brave://settings/languages i saw that English was main language for web.
Changed it to French. Rebooted Brave. Launch Leo : introduction where in French, answers is English.
Cleared data in brave://settings/leo-assistant closed Brave, re open Brave. Accepting new disclaimer from Leo : intro still in French, answers in English.

The weird part is now this: It’s english when we ask Leo to resume a page

But… Sometimes, using without context:

Hi eveyone, I’m encountering the same thing. I’m on MacOS, brave is set to use French. Do you guys found a workaround?

It seems like Leo can’t resume a page (using the context) in another language than English, which is a pitty.

Sometimes even when just chating with Leo, I get back a mix of both english and french, weird.

I have the same problem, my language is set to German.

All of Leo’s menus and the welcome text are in German, but all replies are in English unless it is explicitly stated that the reply should be in German

I hope this will be fixed soon. The AI assistant has real potential, but it annoys me more when I have all the answers in English, even if the original text was in German