For users encountering NET::ERR_CERT_DATE_INVALID Error

Okay, I did everything, then I ran into these two steps:
Step 1: click the plus sign, see screenshot (can not just add it)
I overcame this by dragging the file and dropping it in while login was selected; so then file was added.
Step 2: says not trusted, see 2nd screenshot
What do I do now?

Ok nice, now right click on the ISRG Root X1 and select Get Info, a new popup will open, you need to select Trust and click on the Drop down saying When using this certificate and select Always Trust.

Here is a screen shot to make you understand better:
Screen Shot 2021-10-26 at 8.53.47 AM

Hope it Helps :smiley:

1 Like

Fakelf:
Okay, I got it. I was right clicking to look at get info, but not getting what I needed; I had to click the small “i” below and it gave me the selector to click trust this cert. Got it.
Thanks so much.

1 Like

You are welcome. If any more questions please ask :smiley:

Bom dia, também estou tendo problemas com o certificado da página, e a hora está correta também, e aparece HSTS está interferindo também, você pode me ajudar?

I dont understand the language you speak, and I am sorry I couldnt reply.

good afternoon, I’m having problems accessing certain sites, but I was able to access normally before on Brave, and now something seems to have changed

Leila

What is the error. Can you please send a screenshot of the error.

good afternoon, this is the problem that’s happening, and before it didn’t happen, and it happens on other sites too, I don’t know what’s changed, because I haven’t touched anything.

Leila

I have the same problem, but only on some websites. Don’t understand why. I use Win 7. I tried the ISRG Root X1 -fix, fixed some websites, but not all. Then I downloaded some upgrade to Windows 7. But it still didnt solve everything.

Good morning, I normally accessed the appropriate sites, and now I can’t access them, and I need to, because it’s my job

Did you follow the steps above?

Yes, it seems to have solved the issue on some websites, but the problem remains on others. Some websites don’t load proparly, so it’s hard no navigate around those. It says “not secure” on these websites before the url.

Hi. I couldn’t solve the issue I’ve just could erase “2 files DST ROOT CA X3” from Certificates Intermediate Certification Authorities and Third-party root Certification Authorities folders.
this file in Trusted Root Certification Authorities doesn’t exist
Windows 7 - Brave version 1.31.88 chromium 95.0.4638.69 (64 bits)

I maybe should ad that all the non-working websites works fine in browsers like Firefox.

There is the same error ?

the only one conclusion that I have of this issue is the recent updates of Brave did that some versions of some OS failed. I recieve ads on my android but in my Pc’s that have windows 7, stopped recieving ads
Regards

I deleted the certificate DST ROOT CA X3 from Root Certification Authorities (from the others folders were deleted permanently)but every time that open brave the certificate is installed again!!!
and delete again, open… and so on

is a kind of joke?
is anybody out there?

It reinstall again on its own because its the certificate needed to browse websites.

IF you are facing the date error check this post out For users encountering NET::ERR_CERT_DATE_INVALID Error - #8 by mrnow Thanks

sorry for delay
the link you put is exactly this thread.
I’m looking for another explanation
Thanks