Fonts too light in windows10; Brave only

Recently received a new dynabook (2020) running Windows10.

I can barely read the fonts in Brave settings and many webpages as they are too light. Changing font, font size, or zoom in Brave doesn’t help. I’ve also adjusted ClearType in Windows10 and changed the font in DuckDuckGo; it’s helped a bit, but still too light to read in many places. Firefox and Edge on the same machine are fine and legible.

Also use Brave on a MacBookPro (retina) and MacMini (junky non-retina display) and have no problem reading the fonts.

The screen on the dynabook isn’t the best, but does anyone have any tips? I’m not too familiar with Windows, but as other browsers look fine, I’m inclined to think it’s something with Brave.

Thanks.

Brave Version: 1.22.71

Hello @tacobot

could you try to disable all extension and try in private mode

if it work then the issue either with one of your extension or you need to clear cache/cookies

also did you tried to change the font from here brave://settings/appearance

hope that help and have a nice day :slight_smile:

I disabled all extensions and relaunched: the same.
I tired in a private window: the same.

Yes, I tired a few different fonts under “Customize fonts.” Some are better than others but all are very light and difficult to read.

Thanks anyway.

Hello @tacobot

go to menu then choose to create new profile and see if that new one look better