Focus Assist issues - Windows 10

Focus Assist in Windows 10 keeps auto-reverting back to “Alarms Only” and thus the adverts keep getting disabled. I have to keep switching it back to Focus Assist in order to get adverts. Is there anything I can do to fix this? Thank you.

Using latest version of Brave.

Thank you for reaching out.
However, this is a Microsoft issue, rather than a Brave issue (although Brave is being affected by it). We do have a Windows 10 troubleshooting guide that goes over how to setup Focus Assist to work with ads which may or may not be useful:

Thank you for that link, @Mattches . I checked it out and found that in Settings, Notifications & Actions, under ‘Get notifications from these apps’, Focus assist (via Cortana) was turned off and greyed out. Further down Cortana was turned off, as I prefer it that way. But when I turned it on, it then allowed me to turn on Focus assist above it. I could then go back to Cortana and turn it off but now Focus assist (via Cortana) remains on, but greyed out.

Hopefully this is now the permanent solution to the issue and also explains why Focus assist kept auto-reverting to Alarms only.

I’ll monitor this over the next couple of days and see if it has cured the issue going forward.

PS - I had previously tried setting Focus assist to Priority only, instead of Off, and customised it to show notifications from Brave. However that did not work either, but perhaps it will now that I’ve done the above fix.

Unfortunately it is still auto-reverting back to Alarms Only, even with the above steps in place.

Reluctantly I have now turned Cortana on in the hope that fixes it, but I don’t hold out much hope of that working because Focus Assist via Cortana was already on; and I don’t like having Cortano on either.

Other than making registry changes (which I’m reluctant to do) I’ve tried everything in your link @Mattches but nothing seems to fix it. The strange thing is I have a 2nd desktop also running W10 which does not (and never has) had this issue.


As I said previously, this is not a Brave issue. It sounds like you are having an issue with Focus Assist, which is independent of Brave. You should contact MS support and inform them about the issue you’e having.

Actually since I turned on Cortana it’s been fine now. Touch wood it stays that way. I don’t like having Cortana on but if it’s the only solution to this then so be it.

Thanks a lot for your assistance @Mattches

Just one other question, should I still get ads through when I use a VPN?

Hm strange – you shouldn’t have to have Cortana enabled. I’ll have to dig around for more information on that (even if it is working for your). And yes you should still be able to get ads when running a VPN although it is discouraged.

Thanks @Mattches . It seems to revert to Alarms Only whenever you do a restart, so you then have to manually turn Focus Assist off again.

@Chancie It would appear many Windows users are frustrated with Focus Assist enabling after a reboot. Please see just in-case you are mirroring displays. Thanks


Thank you @tmancey , I was, so I’ve turned that off too.
Although I still have to have Cortana enabled for ads to get through.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.