Flash games from https://www.lumosity.com/ not working after repeated attempts to rectify

Go to https://www.lumosity.com/. Play the first brain training game in flash that’s fine, then the next game, flash is blocked and doesn’t respond after many attempts to get flash accepted on the site page and under security information.

Brave version : [Version 1.8.96] (64-bit)
OS: Microsoft 64bit, running windows 10
How long has this been happening? since I installed brave (4 months ago).

What I would like to happen: Flash requests from https://www.lumosity.com/ to be accepted by Brave in order for me to play brain training games.

Cleared the cache, still nothing.

growl, not happy jan

Thanks for reaching out. So a couple things pop out at me here:

  1. You state that your Brave version is Version 1.5.123 – this is a very old release. The most up to date version of the browser at this time is v1.8.96. Before anything else, please update your browser and try the site again as there’s a good chance simply updating will resolve the issue you’re encountering.
  2. If you update and still get the same results, try creating a new browser profile (Menu --> Create new profile), then test Lumosity again using this new profile and see if this makes any difference?
  1. I have upgraded the browser to the current version, that is all up to date and still incur the same issue.
  2. I have done the new profile and seen the same results mentioned above.

Tried this again in a new profile, changed the flash settings and turned off brave shields and still failed to load the flash games.

I have even cleared the website cookies. From what I can tell this is a issue with brave, not lumosity.

still not happening at this point and there’s not much more I can do to make this work

I don’t seem to have this issue no matter how hard I try to reproduce.
When I land on a game, the “puzzle piece” icon appears in the address bar – which I click on and select Run flash this time. The piece goes away, then I click on the flash warning (in the player) itself, which launches a prompt, asking if its cool if Flash is allowed for this site. I select Allow, then I’m good to go.

To confirm, you don’t see this behavior in Chrome or any Chromium-based browser?

Mattches the process your pointing out does not work, and will not work.

It may also be one of the many extensions you have installed at this time. But if you claim that it worked on the new profile then I honestly have no idea. The site works for me on Windows, macOS and Linux without any issue. We’re getting down to the more nuclear options:

  1. You can try clearing all site data/cache from your browser (Menu --> History --> Clear browsing data --> [All time])
  2. You can try downloading the Brave Beta and testing to see if you get the same results or if the site will work as intended in the Beta.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.