Flash Again Failing To Be Detected

flash

#1

OS : elementary OS (Ubuntu)
Version : 4.13.0-32-generic - #35~16.04.1-Ubuntu - x86_64

About Brave :

Brave 0.20.30
V8 6.4.388.40
rev 8b78402
Muon 4.7.9
OS Release 4.13.0-32-generic
Update Channel Release
OS Architecture x64
OS Platform Linux
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 64.0.3282.119

I have checked and followed-thru the wiki about getting flash to work. However, it still remains a no-go. Enable Flash remains gray and it cannot be clicked or slid over.

All files appear to be where they are supposed to be.

'# update-pepperflashplugin-nonfree --status
Flash Player version installed on this system : 28.0.0.161
Flash Player version available on upstream site: 28.0.0.161

/usr/lib/adobe-flashplugin
/usr/lib/pepperflashplugin-nonfree/

Both contain the files needed.

Flash is working fine in Chromium

I do not get the option to enable flash when viewing a flash page and there’s no right-click menu or icon/puzzle piece shown on the page where the flash should be.

I have tried disabling shields, but still no flash.

The flash help page shows this:

55

Any clues?

–DGC


#2

So after 6 days, no one has any suggestions?

Anyone?

DGC


#3

Still nothing? Is there a way to enable without having to click the Plugin switch, since it remains grayed out? A config entry, edit a file, etc?


#4

Weeks go by and yet still not a single suggestion? Are we sure this is a support forum?


#5

Hi @DGC,

Sorry for the delayed response. I am able to enable flash on ElementaryOS. Please have a look here

Could you try the following steps

  1. Remove the flash folder you have created under /usr/lib
  2. Visit https://get.adobe.com/flashplayer/
  3. Select Need Flash Player for a different computer?
  4. Select Linux x64
  5. Select FP 28.0 for Linux 64-bit (.tar.gz)- PPAPI
  6. Download the zip file
  7. Extract the contents of the zip file on Desktop
  8. Use terminal to create the folder /usr/lib/pepperflashplugin-nonfree/ with su
  9. Copy libpepflashplayer.so & manifest.json to /usr/lib/pepperflashplugin-nonfree/
  10. Close brave (if open) and relaunch brave and check if flash is enabled

#6

Thanks for the reply.

I did exactly as you outlined above, and yet in Brave the Flash Plugin toggle still cannot be clicked.

Any other suggestions?


#7

Do you have any /usr/lib64/ folder on your installation? If yes could you try moving the two files and check. If no could you try creating the folder /usr/lib64/pepperflashplugin-nonfree/ and then try moving the two files under it and check


#8

No, I don’t have a lib64 folder. Do you know if there’s some other sort of other way to get the option to flip on?

I notice that a new release was just put up:

'# update-pepperflashplugin-nonfree --status
Flash Player version installed on this system : 28.0.0.161
Flash Player version available on upstream site: 29.0.0.113

Pulled it down and checked again:

'# update-pepperflashplugin-nonfree --status
Flash Player version installed on this system : 29.0.0.113
Flash Player version available on upstream site: 29.0.0.113

Enable Adobe Flash Plugin remains grayed-out:

06

I have clicked, double-clicked, click-and-drag, etc. Nothing.


#9

Could you check the permission on the folder? There is an already open issue where Flash isn’t being detected on certain Linux distros. Here’s the issue for reference

In case even after allowing permission you are unable to enable flash I’d add a upvote on your behalf so that the issue gets more visibility.


#10

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.