Firefox settings are hijacking or hijacked by Brave

Description of the issue:
After contacting tech support on many different websites, I have learned that the Brave browser is using Firefox settings.
For instance, when clicking on questions on a FAQ page, the “popups” wouldn’t open. When tech support suggested that I enable popups, I checked on Firefox only to find that enabling popups in Firefox enabled them in Brave as well. I made NO CHANGES to my Brave settings, only Firefox, but suddenly the popups in Brave were working.
Settings on another website were consistently changing without my input. When I went to Firefox and cleared the cache there, Brave settings were once again working as expected.
These are only a few examples.
How can this issue be reproduced?
I have no idea how to reproduce these issues.

Expected result:

Brave Version( check About Brave):

Version 1.35.103 Chromium: 98.0.4758.102 (Official Build) (64-bit)

Additional Information:

@Mattches can you take a look at all of this? Not only the issue here, but what Chocoholic was saying in regards to issue with Brave Wallet when they were trying so send crypto. I guess somehow people are seeing a conflict between the two.

So considering that FF and Brave user entirely different underlying engines, this is not possible. The only possible link between the two would be any OS settings that they share. @Venusc Can you please provide an example website where (if I’m understanding correctly) you allowed website notifications (I assume this is what you meant by “pop-ups”?) in FF and subsequently allowed them in Brave so I can test on my end?

Jumping in. @Mattches let me know if you prefer I don’t.

“Hijack” randomly happening using both Firefox and Chrome. I used IRS Free File Online Lookup tool as an example:

It appears to be random how far can get but conflict occurrence itself is reproducible. Also random what will be impacted in other instances (e.g. the decimal problem in Brave Wallet I had).

Steps I used to reproduce on the IRS site are below. I cleared history/cache on opening each browser.

  1. Open Brave
  2. Open site from bookmark
  3. Open Chrome
  4. Open same site
  5. Enter data on Chrome
  6. Continue to next page. Works as expected.
  7. Go to site on Brave
  8. Enter data
  9. Continue to next page gives error message

Next steps are random. Sometimes, just closing Chrome will remove error and going to next page on Brave works as expected. Sometimes have to log out of Brave and back in to remove the error.

With Firefox and Brave open, if I repeat the above, when switching to Brave I can’t enter anything besides the first prompt and it will not proceed in most instances. Sometimes I can proceed to next page in Brave.

When I repeat with Firefox, Brave, and Chrome all open. And enter data in Firefox, Chrome and Brave both get error messages when go to next page.

It does appear to have random results. Really doesn’t seem to be step by step reproducible because stopping point doesn’t seem to occur at same place each time. Hopefully, you can reproduce yourself. I don’t know when the current Brave version update occurred, so cannot say whether this was also occurring in 1.36.111 or not.

Brave 1.36.112 Chromium: 99.0.4844.51 (Official Build) (64-bit)
Revision d537ec02474b5afe23684e7963d538896c63ac77-refs/branch-heads/4844@{#875}
OS Windows 10 Version 21H1 (Build 19043.1526)

I have avoided opening multiple browsers since posting this. Opened Edge today to test the problem in below post. Had problems with changing Edge settings when both Brave and Edge opened at same time. Related?

Sorry it’s taken me so long to reply. Apparently, I accidentally deleted your message.

When accessed on Brave the following website would not open the individual FAQs.

Same experience when I tried opening the FAQs on Firefox. I contacted the website who replied that everything worked on their end, “please check pop-up settings”. After enabling pop-ups in Firefox I tested on Firefox and FAQs opened as expected. I then returned to the website on Brave and FAQs were opening there as well even though I had made no changes to Brave settings.

I realize that it doesn’t appear to make sense, but this is only one example in recent months where a change to Firefox settings affected Brave results. Unfortunately, I don’t remember exactly what steps I took in the other instance I had that did not involve pop-ups, but involved other defaults on a different website.

Thanks for any help you can provide.

The only possible way this can happen is if there is some application that is controlling OS/system settings for multiple other apps (in this case, browsers). As I said before, it is quite literally impossible for settings between FF and Brave to control one another without a 3rd party app or process doing that work.

Can you think of any OS settings, applications or automations you have running on your computer that might meet that criteria?

Man, I can’t think of anything, certainly nothing that I’ve installed. Can’t speak for what nsa or little god bill gates has on there.
I’m on Windows 10, that I hate, if that tells anything.

I’ll poke around and see if I can find anything.
Could it be an extension that’s installed on both browsers?

Potentially yeah, although unlikely. What extensions do you have installed?

I tried looking for OS settings that may be interfering and couldn’t find anything. I even turned some settings off on my phone that possibly could be interfering even though I do not have my phone and PC linked! I do not use extensions and the only additional installed application that I am running consistently is my antivirus/security software. Could that be it? If so, that is a bummer. No way I’m disabling that!


No, highly unlikely that it’s the AV service you’re using. I would think that an extension or app that controls OS permissions or maybe application launching might affect this but nothing specific comes to mind.

Ah well. Will just have to keep trying to figure it out. Maybe I’ll run across something one day… hope so. I hate being limited on what I can and cannot do as far as opening things on my computer! bah!. :stuck_out_tongue_closed_eyes:

If I run across the culprit, I’ll be sure to post. Thank-you.

I only have 1 extension that is running in both browsers, that is CapitolOne Shopping Extension.
I don’t see how, but could it possibly have something to do with the VPN?
I would be happy to check my os, but I wouldn’t even know where to begin.

Is there any way either of you can submit a short video recording of this behavior? In the recording, I’d like to see:

  1. What a specific permission is set to in both FF and Brave (open both browsers and show the permissions).
  2. Close both browsers
  3. Open FF and change a permission in Firefox
  4. Close FF, then open Brave
  5. Show the permission changed in Brave

@Mattches I’ll try, may take a while. It has been years since I’ve done this sort of thing and I don’t even know if I have software installed to do it. Going to be a learning curve even if I do. Hopefully it will be easier than I’m anticipating atm. lol

I wouldn’t know where to check permissions.
As far as recording the behavior, if I understand what you are asking, I would have to find a website that isn’t working to do that. I don’t have that kind of time. :frowning:

There are a number of easy to use screen recording tools available — some suggestions here:

You do not need to find a site that’s not working, you only need to test the behavior you’re describing. So for example, you can view a list of permissions for a site in both browsers by doing the following:

In Brave:

  1. Visit a website (I’ve used for simplicity)
  2. Click the “lock” icon in the address bar
  3. Then Site settings
  4. You will then see a list of all the permissions set for the site

In Firefox:

  1. Visit a website
  2. Click the “lock” icon in the address bar
  3. Click the > next to Connection secure
  4. Click More information
  5. You should now see a list of permissions allowed for the site

Here is a short screen recording of me performing the same behavior I’d like to see from your perspective(s) on my end. This was taken using Screen-to-gif:

Also note that the permissions in Brave for me did not change after changing the same permission in Firefox.


@Mattches No video. Retesting with works as intended in Chrome, Firefox, and Edge and can have all browsers open simultaneously.

Was working in Brave with only Brave open. First instance of loading Firefox and Brave simultaneously caused an error in Brave. After that, I cleared Brave cookie/javascript/ and site permissions closed and reopened Brave/site and still broke. Repeated clear/resets, closed Brave and rebooted computer. Error still occurs. I guess I broke that one!

Now site either doesn’t work at all or I have to turn off shields. Then I can enter first page data but on second page I get the error even with shields down. Tested in Release and Beta and created new profiles for both. Does not work in any of them. Started getting 404 error intermittently.

In the test profiles, I set history to clear everything on exit , checked/cleared permissions for javascript and additional site data, also tried rebooting computer and testing and still doesn’t work. Must be something unique with my computer at this time.

Started getting a 404 error and now have a 403 error. Guess the IRS banned me for spamming their app! Anyway, setting this aside. Thank-you for your patience in this matter.


Appears anti-virus software settings may have been problem afterall. Who knows. Just thought I would share.

I don’t use VPN with Brave but I do with other browsers. Got the idea that my VPN may be interfering from this post: "SITENAME" DNS address could not be found. Diagnosing the problem. DNS_PROBE_POSSIBLE - #3 by jumpingjax

Opened Firefox, opened anti-virus dashboard, and turned VPN on to reset. Started getting issues with Firefox. Called anti-virus tech support. They walked me through resetting VPN and changing wi-fi security settings per VPN in the anti-virus software. Rebooted computer and problems with Firefox resolved. So… settings/conflicts with anti-virus, VPN, and wi-fi may have been the underlying issue for unexpected results in other browsers.

I would give you more detail but I really didn’t understand what was going on and why I was enabling/disabling different things. All got very confusing and just followed instructions given and left trying to understand by the wayside.