Fingerprint protection toggle is broken when enabled in Settings


#1

This is a continuation of Articles from medium.com are missing embedded content

First, let me say that I’m a bit dissatisfied that my issue was closed prematurely with ONE single report of things supposedly working, without any further investigation into that users report…

I did a play store report, was bounced here and had to sign up… I invest my time to investigate and reduce the error space and then I’m blatantly ignored, so thanks…

Here’s some stuff I was planning to write, only to find my issue closed…

Anyway, I tracked down the issue for you. It’s two-fold:

  1. Fingerprint protection breaks embedded content (e.g. images, also others) on Medium posts, possibly only posts that don’t originate from medium.com, but this is unconfirmed
  2. Toggling fingerprint protection in the Brave panel or settings does not work when Settings > Privacy > Fingerprint Protection has been enabled previously

To expand on #2, disabling Fingerprint Protection in settings requires opening a new tab for the setting to be disabled (at least only then do the medium resources load). So this made tracking this issue hard, no amount of toggling helped because I had not opened a new tab.

PS. The reason I was able to track this down was that fingerprint protection broke the site on desktop (macOS) Brave as well. Difference being that toggling worked there.


Display incorrectly blocked images
#2

Hi @RollerCoaster,

I’m sorry for the inconvenience. I re-open your previous issue and you can continue the discussion of your previous issue there.

And about the fingerprint, yes, it can break some site. Disabling fingerprint protection should solve the issue.
Also cc @Serg and @LaurenWags since I can not reproduce #2.


#3

Hi @RollerCoaster

I am unable to reproduce your statement of

When I toggle site settings I am using the Bravery icon and the site reloads automatically. So I was wondering if you could tell me which version of Brave you are using.

Thanks,
Lauren


#4

Thanks eljuno!

@LaurenWags I’m using the latest one from the Play store: Brave 1.0.23, Chromium 590.3701.92.

The reproduction steps are as follows:

  1. Open Settings > Privacy and make sure Fingerprinting Protection is enabled (selected)
  2. Open a new tab (important, do not reuse old one)
  3. Navigate to the Medium article linked in the issue report
  4. Try to toggle Fingerprinting Protection in the Brave shield panel (has no effect even if page is reloaded)

#5

Thanks for the excellent detective work @RollerCoaster

I’ve logged an issue and put the link below so it can be tracked.

Lauren


#6