Fill suggestion doesn't work correctly with a password management extension

Description of the issue:
Form filling suggestion doesn’t work when a password manager extension is active (Bitwarden, Microsoft).
When I deactivate the extension, the suggestion to fill in the form field appears again.

How can this issue be reproduced?

  1. Install the BitWarden or Microsoft AutoFill extension and activate it;
  2. Open a page that contains a form with data that you have previously filled out and can use the filling suggestion.

Expected result:

The form will not present an option to fill it out, it will be as if you had never filled it out before.
But, if you deactivate the extension, the filling suggestion will appear again.

Brave Version( check About Brave):
v1.64.109

Additional Information:
I tested it on the Beta and Niglthy versions and got the same results

@agovieira to be clear, do you have information from the sites saved in your BitWarden and all?

When you have those installed, they tend to take over the password manager. In other words, anything you have saved in Brave will not be accessible. Instead it will look to your extension by default. So when you say the form doesn’t present an option, it seems there’s an issue with the extension.

Then when you disable the extension, it goes back to Brave. So Brave then offers you the autofill option based on what you have saved in the browser.

I haven’t downloaded the extensions to test them out, but did want to start off with some of the “obvious” possibilities might be.

  1. Check settings in your extensions themselves.

  2. Go to password manager settings at brave://password-manager/settings and see if you have anything there. (I’m not sure how current shows compared to how they used to have it in prior versions, I hate the new format)

Thank you very much!
I carried out some tests and overcome the problem.

  • I disabled the option to make BitWarden my default password manager.
    This way I can use it and see the information saved in the browser.
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.