File type associations are unreliable in Windows

Looks like you’re running into the “blank window” issue. Please see the solution found here to resolve:

Ok I resolved the links not working in Brave and I now have Brave working as my default browser

  1. unInstall the old version of Brave the pre-chromium code base. (Muon).

  2. Manually delete the folders that the old Muon Brave code base would not remove. (See thread for details, also see for reference Outlook Email Links do not work on Version 0.62.51 Chromium: 73.0.3683.103 (Official Build) (64-bit))

  3. Uninstall the current brave browser installation.

  4. Reboot

  5. Open the registry and manually remove every reference to Brave from my Registry. If you are not Brave enough (boom tish) to remove these manually you may want to use some registry clean up tool.

  6. Reboot

  7. Install the latest version of Brave and Voila everything now works and Brave is my default browser.

While I understand the enormous task of moving the codebase to Chromium my feedback to the Brave team is that these are rookie installation errors on the Windows platform that could and should have been forecast and addressed and it is apparent to me that Brave needs to automate and increase their QA efforts immediately if they are really going to get traction with this browser and approach. I believe they have incredible potential to do that with better QA, Good Luck

So, I tried the RegEdit method, and it originally did not work. I tried pasting the URI into Run, which said that the path did not exist. The correct URI has a space between Files and (x86). I tried that instead in RegEdit, which opened a new browser but did not pass in the URI. So, I removed the two dashes, and it worked.

The final value was: "C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" "%1".

Thank you for leading me down the right path.

Hopefully this helps others.

1 Like

@jdenbley,
Great find! I’ve edited the steps in the original post to reflect this alternate path should the original not work (I added it as an alternate because users (myself included) have been successful with the original path), as well as fixed the missing space in the original path.

Thank you again for the help and diligence!

1 Like

Hi,

New Brave user here.

I use Outlook 2013. Since using Brave I cannot open links in my emails. I have checked Settings in Win 10-64 to ensure Brave is default browser and that .htm and .html suffixes are set to Brave. I have also modified the registry and tried both versions of the address, all to no avail.

What else can I try?

Thanks,
Mike

@wmd,
Can you tell me what happens when you try? Some users have reported that Brave will launch but just open a blank new tab page, others report it not launching at all – what do you see on your end?

Hi Mattches,

I get a message box stating’ Your organization’s policies are preventing us from completing this action. …’

This seems to be an issue with Microsoft and Chromium-based browsers, based on my research. I’m surprised I hadn’t come across this before.
Here’s what I’d recommend to start:

  1. Can you try changing your default browser to IE/Edge, FireFox or any other browser installed? Note that I think you should actually do this by opening the browser and using whatever prompt/menu options it has to change this setting.
  2. Confirm that you’ve done so by checking your Default programs again and you should see the newly selected browser listed under .HTML, .htm, etc
  3. Confirm that you can open links from Outlook in the newly selected default browser
  4. Now, return to Brave and elect to make it your default browser. If you’re not prompted to on launch, go to Settings --> Default browser and select Make default.
  5. Return to Outlook, click a link and observe what happens.

Let me know the results.

Changed back to Firefox - confirmed as default, checked that relevant suffixes were also so associated and tried to open a link in Outlook, failed with same message. However I not not changed or removed the Registry entry.

Regards,

Mike

@wmd,
Thats weird. In Windows, go to Settings --> System --> Default Apps --> Reset to restore the default Windows filetype associations. This way we can start with a clean slate.

Confirm that when you click a link in Outlook, it defaults to/opens with Edge (maybe IE?). After this, go ahead and try making Brave your default browser again and let me know the results.

Reset to default, checked that it had, also the suffixes. The same problem persists. N.B. I have not removed the addition to the registry.

Regards,

Mike

Searched the web and found a MS fix package which once run and my defaults set back to Brave and Outlook 2013, the links now work. Thanks for your assistance.

Regards,
Mike

1 Like

@wmd,
Very glad to hear that! Would you mind sharing the link to the package here so other users encountering this issue can also try your solution?

Here is the page address for the MS fix. It refers to IE but this is to set everything in the affected area back to original condition . once done then change settings for replacement browser.

Cheers,

Mike
N.B. Just click in the box to go to the MS Info

1 Like

It would seem my .pdf file uploaded to my page is not being seen at all there is supposed to be a Download button or if you click the Poem title it should allow the user to download the .pdf document

This seems to be the same problem I had yesterday, uploading a .jpg or .png file to uphold.


Chrome worked straight away with the exact same image.

1 Like

@ZerosNOnes, I actually think this is a separate issue – you were trying to KYC and upload a drivers license or some other identification to Uphold, correct?

Did this happen with an image that was (confirmed) to be a .jpg or .png?

1 Like

That’s correct, @Mattches.

And yes, it’d was a .jpg and .png. I tried both file types. Legit file types, not just renaming.

@ZerosNOnes,
That’s very strange – are you using default Shields settings and, if so, when you open the Shields panel, do you see a Device Recognition attempt blocked?

1 Like

You were right, I tried a dummy uphold account to test that. As I uploaded, the site attempted to identify my device. I turned the shield off and it uploaded fine :wink:

Thanks, Mattches.

1 Like