File type associations are unreliable in Windows

Description

Modified from issue #2821:

Setting Brave as a default program for file types produces inconsistent results. Many users report being unable to open links from external apps.

This applies to any way in which file type associations are made:

  1. Via reg/command line args
  2. Open With... --> Always open... from context menu
  3. System Settings --> Choose a default app for each type of file

Steps to Reproduce

Use any method to associate a file type/extension ( .jpg , .html , .tiff , etc) with Brave.
Test the association by opening a file of the appropriate type.

Potential workaround

It seems like the registry path for some users points to the wrong directory. Some users report that editing this registry key resolves their issue while others report that it does launch Brave when the links/files are opened, but Brave only launches a new window w/new tab page (instead of opening/navigating to the appropriate URL).

Steps to edit Windows registry keys (if necessary):

  1. On your Windows machine, with no Brave instances open, use the start menu search bar and type regedit , hit enter

  2. Select HKEY_CLASSES_ROOT from the side bar

  3. In your Registry Editor at the top, append \BraveHTML\shell\open\command to the path. The full path at the top should now read Computer\HKEY_CLASSES_ROOT\BraveHTML\shell\open\command – hit enter

  4. You should now see a path appear under the Data column in the editor. Copy/paste this value somewhere in the event we need to re-enter it later. This value must match the location of the Brave executable file and it’s likely pointing somewhere else which is causing the issue.

  5. In the registry editor, modify the path to point to "C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" --"%1"

    • As noted by @jdenbley below, if the above path does not work for you, try this modified path and see if you get the same results:
      "C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" "%1"

Further testing

I’d like to get some additional data on the issue by testing a few different scenarios and comparing the results. If you’re encountering this issue and would like to help diagnose this:

  1. Ensure Brave is set as your default browser
  2. Set both the .html and .png file types you’ve associated the following file types to open with Brave (even if these types don’t apply to your issue in particular).
  3. Follow the steps in the above section to edit your registry key to reflect the appropriate path if necessary.

Once the above steps are complete, please try the following and report what you find:

Test 1 - Save a web page (use right-click --> Save As... or File menu) or save open a text editor and save the file as .html to your desktop. Close Brave, then open the file.

Test 2 - Open a hyperlink from an external app (test as many as you’d like – can’t have too much data). You can use an external mail client if you have one, create a link in a Word or Excel document, click a link in the Discord app, etc. Be sure to note which apps you used.

Test 3 - Save or use a pre-existing .png file and open the file.

Please let us know the results of your tests and which Windows OS you’re using.

Description of the issue:
Link clicked from an application (e.g Windows Mail app) doesn’t open in Brave.

Steps to Reproduce (add as many as necessary): 1. 2. 3.
Open any application and click on a link

Actual Result (gifs and screenshots are welcome!):
Nothing happens.

Expected result:
Brave opens the link

Reproduces how often:
Always

Operating System and Brave Version(See the About Brave page in the main menu):
Win10 17763.379 + Brave Version 0.62.51 Chromium: 73.0.3683.103 (Build officiel) (64 bits)
Also happens on a computer with W10 Insider preview build + Brave Beta build

Additional Information:
I made sure Brave is my default browser and was the default app for http/https protocol and htm/html files. I tried to uninstall and reinstall Brave.

Apologies for late response @sanzo,

I’m unable to reproduce the issue on my laptop. It’s work as expected and opened Brave.
cc @Mattches @gsarvadnya for additional assistance.

@sanzo,
We have an open issue for this but I believe there is a fix for it but you’ll have to modify your Registry.
Please try the following:

  1. On your Windows machine, with no Brave instances open, use the start menu search bar and type regedit, hit enter
  2. Select HKEY_CLASSES_ROOT from the side bar
  3. In your Registry Editor at the top, append \BraveHTML\shell\open\command to the path. The full path at the top should now read Computer\HKEY_CLASSES_ROOT\BraveHTML\shell\open\command – hit enter
  4. You should now see a path appear under the Data column in the editor. Copy/paste this value somewhere in the event we need to re-enter it later. This value must match the location of the Brave executable file and it’s likely pointing somewhere else which is causing the issue.
  5. In the registry editor, modify the path to point to "C:\Program Files(x86)\Brave-Browser\Application\brave.exe" --"%1"

Note that you may need to reboot your PC before changes take place. Please let me know if this works for you or if any of the above is unclear.

Thank you. Brave does open now, but the link still does not. It just opens a new blank window.
By the way, changing the registry path to "C:\Program Files(x86)\Brave-Browser\Application\brave.exe" --"%1" was not working. I checked my Brave directory and changed path to
"C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe" --"%1"

@sanzo,
My bad, definitely intended to type BraveSoftware in path. Good catch.
Is this the case for all apps that contain links?

I love Brave but email hyperlinks are not working at all whether shields are up or down and this means I am going to abandon ship unless they are fixed.

Shields up or down make no difference and the link works if I copy and paste it. Brave is my default browser, and this works fine in chrome or edge, this most basic of feature has to work.

Help

@Gunta,
What OS are you using?
We’ve had some issues with email links in Brave before, are you using the Outlook web app, or is Outlook installed on your machine? I imagine it’s the latter of the two.

Also, when you say hyperlinks are “not working”, can you elaborate a bit? What happens when you click on the link? Are any error messages shown?

I am using Windows 10 the latest and I am using the Office 2016 Outlook Desktop client (the latest). Any hyperlink that would normally throw to the browser does not work it just does nothing at all no browser window no error. If I change to Chrome or Edge as the default they work immediately, so this is definitely a Brave issue

Please help me kick Google to the curb, you guys have come so far with this browser and especially with critical extension support in Chromium you cant make these glaring errors without work arounds or being able to trace the root of the problem.

Update: I confirm it has nothing to do with outlook any hyperlink gives me the same behavior for example the hyperlinks in an excel sheet give me the same beviour

@Gunta,
Thank you for the additional information.
I believe that you’re running into a known issue where the Windows Registry key for brave HTML files is pointing to the wrong path. I provided a solution in a previous thread:

We have an open issue for this but I believe there is a fix for it but you’ll have to modify your Registry.
Please try the following:

  1. On your Windows machine, with no Brave instances open, use the start menu search bar and type regedit , hit enter
  2. Select HKEY_CLASSES_ROOT from the side bar
  3. In your Registry Editor at the top, append \BraveHTML\shell\open\command to the path. The full path at the top should now read Computer\HKEY_CLASSES_ROOT\BraveHTML\shell\open\command – hit enter
  4. You should now see a path appear under the Data column in the editor. Copy/paste this value somewhere in the event we need to re-enter it later. This value must match the location of the Brave executable file and it’s likely pointing somewhere else which is causing the issue.
  5. In the registry editor, modify the path to point to "C:\Program Files(x86)\Brave-Browser\Application\brave.exe" --"%1"

Note that you may need to reboot your PC before changes take place. Please let me know if this works for you or if any of the above is unclear.

Let me know if this solution works for you.

Ok I did that, Note the path to my brave executable was not the same as you specified it was this

“C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application\brave.exe” --"%1"

While this has NOT fixed the problem it has changed the behavior. It now fires up a new Brave Window but does not load the hyperlink in the window.

What is the next step to get it to do what its told?

BTW its firing up a new window for every link with the text in brave saying new tab, this is not the behavior expected it should fire up a new tab in the existing window. And even though its boldly stating that’s what its doing its clearly firing up a new screen everytime.

See here the screenshot https://www.dropbox.com/s/qljon6ib7unjtil/Brave%20Linking%20Issue.png?dl=0

I really want to use Brave every day of my life but this level of defect scares me you should have automated regression and smockstack testing that does not allow a build into the wild with such ass on fire defects.

I dont understand how this defect makes it out the door.

@Gunta @sanzo,
I’ve merged your two threads as you both seem to have more or less the same issue and the same results after Reg edit. I’ve provided some tests above – mostly for other users, but if you’re willing to testing anything you haven’t tried or simply reply with your results to help keep things organized it would be greatly appreciated.

I have the same issue, but it didn’t start until I uninstalled Muon. If I had both browsers installed it would open hyperlinks in Muon, not in core. I could not select between them in windows to set the b rowser. they were the same to WIndows. when I uninstalled Muon I was no longer to able to open hyperlinks. WIn 10, fully patched, latest core build. You need to out an uninstaller in to place that actually removes all traces of Muon on a core install. For some reason Win 10 cannot distinguish between the two.

@mbrosemer,
After uninstalling Muon, navigate to ~\AppData\Local\brave and ~\AppData\Roaming\brave and delete both of these directories. This is where Muon store(s) installation and profile data.

Interesting. I found those locations, deleted them, uninstalled Core, deleted the braveSoftware folder in AppData\local, ran revo pro to remove the half dozen things brave left on my system. changed my default browser to IE, was able to get to links just fine. Reinstalled Core. Changed the default browser back to Brave. Same issue. I get this funky error message if i try to open out of an office doc. If I use another program that calls a web page i get a slightly different message about the resource cannot be found.
Can I get a copy of Muon to test some things out? I want to try reinstalling it and see if the behavior goes away.

@Mattches did you see my reply?

thanks

Brave Muon repo is archived but accessible:

Been a few days but about to start testing. Where is the build that fixes these issues. Not getting registry entry paths and associations right in a build is frightening rookie software stuff that should not be in a product professing to replace Google Chrome. I personally love Braves approach to life on the web but I am also a busy professional. I ll battle on a little longer as I want Brave to work but this is disappointing.

1 Like

Ok I noticed I had two copies of Brave installed and can only assume that one of them is the old Legacy Brave versions (MUON). See screenshot here

I removed the old version and rebooted. Same result the link fires up an empty Brave Browser window.

I them followed some further advice here to remove the brave folder from app\local data and app\roaming which I have now done.

Rebooted and now I have the same result still a blank Brave window.

What is my next step? I guess I could uninstall Brave and re-install but I am worried I will lose all my bookmarks and folders neatly set up on my bar.

Right now back to Chrome as my default until my next window to troubleshoot this.

Help.