Figma is really laggy

For my studies, I need to use Figma. Unfortunately, the Brave browser uses a huge amount of resources for it and is also lagging.
I can draw a normal rectangle and move the artboard around and it lags always as if the framerate was like 5fps (in other browsers it’s smooth).
(see video)
Also, you can see the huge amount of resources that the renderer needs. The energy impact goes well over 300 percent whereas in other browsers it’s maximum 100 percent.

In any other browser I tried, I didn’t have any lags (Chrome, Firefox, Safari).

Video:

My device:

Seems like the video doesn’t work. Here it is: https://vimeo.com/441985318

@ma77hiaz,
Thanks for reaching out to us. So on my end, Figma seems to be responding just fine – no lag or frame rate drop of any kind that I can see. Can you tell me what you have your Shields settings configured to for the site? Additionally, what is the extension that you’re running next to Lastpass there in your browser?

@Mattches
Thank you for answering.

Those are my shield settings:


Although disabling the shield doesn’t make any difference.

The addon that’s there is called Notion. Great tool btw, you should check it out! (notion.so)

I am starting to feel like there’s something wrong either with Brave in general or I need to reset my computer.
Because when I tried to install Brave beta recently it always crashed on startup (and as I remember right, it was the same with nightly). Might that be something that’s wrong with my computer? Seems like it’s holding something against Brave :joy:

I have to say that all of the other browsers out there are working perfectly well though.

@ma77hiaz,
Can you try leaving Shields UP, but changing the Fingerprinting option to Allow all... and see if this has any effect on performance?

@Mattches nope, doesn’t make any difference. still the same…

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

OOH, it was disabled already!
Now that I enabled it, it works perfectly :slight_smile:

Thank you!!!

1 Like

@ma77hiaz,
My pleasure! Glad that resolved the issue for you.