Feedback: Rewards Card Acting Weird on NTP in Beta

Description of the issue:
How can this issue be reproduced?

  1. Loaded NTP - NaN was displayed in Token Balance instead of Gemini balance. At brave://rewards, I was connected to Gemini and the information (balance) was displaying correctly. Tried refreshing page a few times but that didn’t work. Opened another NTP and same display. Just continued using Brave and noticed a little while later, the correct balance information was displayed. Eventually closed the NTP and kept doing other things.

  2. Opened another NTP and a “loading” spinner just keeps spinning and is still spinning. Again, refreshed page several times with no impact. Also closed and opened the NTP with same results. And brave://rewards was still displaying accurate information.

  3. Closed Brave Beta and could not reopen. Finally got to open. No idea why. Right clicked on tray icon and selected new window and Beta (and my normal window with saved tabs) then opened. “Loading” spinner still displayed under Token Balance.

  4. Cleared browsing data for all time, refreshed page and no change. Exited and reopened Beta and no change to NTP but now Your Balance at brave://rewards has a spinner. It shows I am still connected to Gemini. Estimated earnings are at 0, but it is not uncommon for the estimated earnings at brave://rewards to take some time to display.

  5. Toggled Brave Private Ads on/off a few times and at first nothing, then balance displayed at brave://rewards and on NTP. Estimated earnings still not displaying as yet at brave://rewards, but they are (and have been) displaying on the NTP.

Expected result:
Gemini Token balance to display.

Brave Version( check About Brave):

Brave 1.50.78 Chromium: 111.0.5563.50 (Official Build) beta (64-bit)
Revision 39f3dfc5023fe60997adc4f6cf5439cfa3e6968a-refs/branch-heads/5563@{#903}
OS Windows 10 Version 22H2 (Build 19045.2604)

Additional Information:
Just thought I would report. Just weird. Will let you know if keeps occurring or if this was a one-off.

For me, it works good in the rewards card but when I go to brave://rewards, it keeps on doing the loop for loading my balance

@SmartyAadi Did you try toggling Brave Private Ads off and on a few times? It didn’t change anything immediately, took a few but my information was eventually displayed.

Or is it working now without doing a thing?

Did try it initially but to no avail. Will try again. Just checked again, its not showing. Oops, I forgot to mention that I am talking about Brave Nightly and not Brave Beta. Sorry.

Oooh, interesting. Was only occurring in Beta for me. I’ll have to check Nightly later to see if it is popping up now. Hope this doesn’t impact payouts. lol

Edit: Just checked Nightly. NTP card displaying information. Did get a loading spinner at brave://rewards but resolved shortly and information displayed. The estimated earnings had changed from the NTP display, but once info displayed at brave://rewards, the NTP was updated.

@SmartyAadi If your display hasn’t resolved, might try clearing browser data for all time, exiting and reopening Nightly, then toggling Rewards off and on. Maybe it was the combo of actions that cleared the loading spinner and not just toggling Rewards off and on. When I clear browsing data for all time, I leave passwords option unchecked. If you have passwords saved, make sure you uncheck that box.

1 Like

Nah, I am not connected, from unsupported region so can’t connect.

Alright, thanks. Have tried it. Will update if anything changes.

1 Like

Ah, more information! So, appears it may be happening randomly to both verified and unverified users. Of course, 2 users ain’t much of a data set but that it is happening at all is interesting. Checked and working fine now in all versions (Release, Beta, Nightly).

What OS are you on? I’m on win10.

Lucky you!.

Win10. It does show up in brave://rewards-internals.
Noticed when going through logs that it says
‘[04 Mar 2023, 9:54:53.1] Failed to fetch balance for gemini wallet!’ whenever I try to go to brave://rewards, could it be a bug which thinks I am connected to Gemini inspite not connected. I did try to connect to Gemini a few times a few days back.

No idea. lol

Since you don’t have to worry about losing earnings, you may want to just do a reset and see if that makes a difference. Let me know if you try and it works!

Well, well. I would have. I have some vBATs. I am waiting to see if Brave brings India back by April or not. If they don’t, I’ll just tip some creator, lol.

Well, FUC* . I made a new profile and while deleting the new one, accidentally deleted the old one. Too st upid of me.

Ahhh. That makes sense. Still if you want to give it a shot, follow the reset information in this Brave Help Center article:

I wouldn’t do it since there is a chance Brave wouldn’t make it good even if you do provide them with the information in the general info tab at brave://rewards-internals. Just posting the information for anyone else more daring who may want to give it a shot. lol

Of course, you could submit a request to Support, provide the information in the General Info tab, and ask them if you should reset to clear the loading spinner and if you do, will they restore any lost earning. If they tell you to go ahead, they’ll make it good, then your covered. :slight_smile:

Again, this is mainly for anyone else reading this and experiencing this issue. :slight_smile:

Edit: Make sure you back-up your Brave-Browser folder so you can restore from the back-up if needed.

I already deleted the main profile and lost the vBATs, Ughhhhhhh. Me being sleepy has it’s problems lol

Oh no! So sorry. That is a shame. :frowning:

But… did it stop the loading spinner? Curious minds want to know. :stuck_out_tongue:

And go get some sleep!! :slight_smile:

Well, since now. There isn’t gonna be any vBAT in my brave rewards wallet, can’t say.

The Rewards balance should still display a zero balance. The loading spinner would “disappear”.

Unfortunately, that is not the case. There’s nothing much to see.

Hmmm, what happens when you click “Connect account”? I think you should be able to see brave://rewards panel, auto-contribute, and tip options even if you cannot connect to a custodial provider.

Also, you may want to ask Support if there is anything they can do to help you recover your earnings. Do you have a back-up of your Brave-Browser folder you can restore? Dang, should have suggested that earlier. My bad. I actually didn’t think you would do it!!!

Nah, man. I did go through some posts about recovery, seems the folder that should be there for old profile is deleted already so don’t think much can be done.

Just keep selecting options until you get to the actual page of custodial providers. Select your previous custodial provider and then exit once it tells you your country is not supported. I think. It has been a while since I played around with this.

This is what happens. The buttons are enabled through the flag called ‘Always show Brave rewards custodial option’