[Fedora 29] Public key for brave-browser is not installed

linux

#1

Hello guys, sorry people didn’t like the update. In my opinion, it looks really smooth! I already updated it in my Windows machine at work but at home I’m having an issue when upgrading with dnf. It’s similar to this previosly reported problem: GPG check failed on Fedora

Description of the issue: dnf upgrade throws the error

Public key for brave-browser-0.57.18-1.x86_64.rpm is not installed.
Error: GPG check failed

Steps to Reproduce (add as many as necessary): Open terminal and enter

sudo dnf upgrade brave-browser

Actual Result (gifs and screenshots are welcome!): Terminal throws error

warning: /var/cache/dnf/brave-browser-rpm-release.s3.brave.com_x86_64_- 
d55d330619c02b48/packages/brave-browser-0.57.18-1.x86_64.rpm: Header V4 RSA/SHA512 
Signature, key ID 6a8a26f9: NOKEY
Public key for brave-browser-0.57.18-1.x86_64.rpm is not installed

Expected result: Normal upgrade. The packaged had been installed and upgraded before and didn’t require to import another public GPG key

EDIT:

I tried to import the keys per the instructions here https://github.com/brave/browser-laptop/blob/master/docs/linuxInstall.md but the upgrade still fails with the same error.


#2

I’m also having this issue.

For me, keys.asc on amazon’s server has fingerprint 5AB4 CA7A C2F9 3FE3 EBD6 082D 6ED1 9DBB 448E EE6C

Meanwhile, brave-browser-0.57.18-1.x86_64.rpm is reported by rpm on my system with the same key id as sameyepatch: 0b31dba06a8a26f9. I’ve placed the file on ipfs at https://gateway.ipfs.io/ipfs/Qmcj9hjmTWCRVHiYy85EVcGkRnwq5XkMWBusujxA7CfQQa .


#3

Same problem. It was blocking me from running dnf upgrade. Fixed by remove Brave Browser :stuck_out_tongue: It looks like a regression.


#4

I know you’re kidding about removing Brave Browser completely but for those who can’t apply updates just because of this issue, dnf has a flag to exclude packages from an upgrade. Just run sudo dnf upgrade --exclude=brave-browser or sudo dnf upgrade -x brave-browser and it will upgrade everything else.


#5

Wasn’t kidding at all. Brave seems to have pushed out a broken package again. I wasn’t able to update my system. I’ll come back to Brave in a while when maybe the packaging process has been fixed.


#6

Looks like it’s related to some major project update or transition?

sudo rpm --import https://brave-browser-rpm-release.s3.brave.com/brave-core.asc

#7

Importing this one solved it, thanks a lot man.