Facetime Camera Disabled


Description of the issue:
I am using a mid 2011 iMac running OS 10.13.6. I have 24G Ram 3TB HDD and after launching Brave I can no longer activate my Built in Camera on Face Time or FB Messenger. I get a message that says “no camera available”

How can this issue be reproduced?

  1. Launch Brave
  2. Launch FaceTime

Expected result:
Tell me how to re-enable the camera or if it is a bug, please fix

Brave Version( check About Brave):

Version 0.69.135 Chromium: 77.0.3865.120 (Official Build) (64-bit)

Additional Information:

Quiting Brave does not restore functionality. If I reboot, the camera capabilities will come back and I haven’t had any further issue until I relaunch Brave. This issue first occurred after I installed Brave.

Thanks,
Walt

Hi Walt, what do you see on this page? brave://settings/content/camera

Send me a screenshot please :slight_smile:

Hi Asad,

Thanks for getting back to me. I had to type the url in manually, it did not link and here is the screen shot. I am guessing I need to turn ask before accessing off?

Thanks,

Walt

@solidground,
To clarify, this behavior happens every/any time you quit and relaunch the browser?

I It never happened before I installed Brave. I turned “ask before accessing” off and it hasn’t happened since. I cant say for sure it happened every time as I only installed the app about 3 days ago and have only launched it about 10 times or so. mostly checking it out. If I power cycle the iMac, it has always reset.

Wish I had more info,

Walt

@solidground,
What I would recommend is, when you go to Facebook or any site where this is known to occur, open your Shields panel in the address bar and change the Device Recognition setting to Allow all... and see if you get the same behavior.

OK, I can do that. Should I turn “ask before accessing” back on? It seems to be working right now with that off. Also, once it locks up, i have to reboot the iMac to enable the camera again.

Thanks,

Walt

It’s actually strange that it’s working with the option set to Blocked. If you click on the “lock” icon in the address bar, what permissions does it say you’ve granted the site?
(example)

I’m sorry but I’m not sure where you are. I’ve only had the app a couple of days and dont know my way around yet. This is what I am looking at. This is what I was told to look at first. If you look in the upper right hand corner, It doesnt look as if the shields are available here. I have to go in under preferences to get there.

Also, I dont see a lock icon on the address bar. And I’m not sure what site you are referring to. I havent been dealing with any sites. After I installed Brave, when I went it to turn my FaceTime app on, I received an error that said there was no camera. I’m happy to try whatever I only need direction on how to get there.

Thanks,

Walt

:point_up: This is the site I was referencing earlier (FB Messenger).

So to clear a few things up, the “lock” icon is located here:


Clicking that icon will show you a list of site settings and some other options as well, as shown in my above image.

What I’m wondering is if your iMac thinks Brave still has control of the camera even after its closed. So my first question/test would be,

  1. See if you can open Brave, browse normally, then open FaceTime (or any other application that’s not in the browser, that uses the camera) and have the camera be detected and work as intended. If yes, then try moving to #2 below
  2. Try the same steps as above, except login to FB messenger and use the camera. Then, with the browser open, launch facetime and see if it works. If not, close/quit the browser and see if it works.

If neither of the above situations are possible, Brave is indeed interfering with the camera somehow and we can further troubleshoot the issue.

Thank you! now we are on the same page. I was doing everything through my email and not the community so I didn’t know what you were talking about.

OK, this is what I am seeing right now. With Brave launched, it I go directly into the FaceTime app, the camera is working. (different from before)

If I go to FB in Chrome with Brave open the camera works.

If I go into FB in Brave, the camera doesnt work and I get the following:

If I click on the lock key that you spoke of before, This is what I ssee:

27%20PM

I am guessing that I will need to change the camera setting to allow? and where to allow the microphone. Or are they one setting?

Thanks,
Walt

@solidground,
Apologies for the late response.

This is correct! You can set it there from that menu in the image you shared, you can also check in the address bar on the right side, where the site may be notifying you that it’s asking for camera access:
image

After allowing camera/microphone access, if the site still isn’t working as intended – open your Shields panel while on FB messenger site (lion icon in the address bar), and change the Device Recognition setting to Allow all device recognition:

This topic was automatically closed after 30 days. New replies are no longer allowed.