Extensions Preference box appears on top of passwords box blocking view of some passwords

<----Please try to adhere to this template when reporting bugs and delete this top section between and including the arrows when posting! ---->

Description of the issue:

Steps to Reproduce (add as many as necessary):

  1. Scroll down to Passwors Preferences
    2.See extensions preference box on top of passwords
    3.Think about going back to using Firefox

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Brave Version(about:brave):

Reproducible on current live release (yes/no):

Additional Information:

@Fistfullofknuckles please see Visual bug in font settings.

The fix will be available with 0.65.x release (if not changed).
Thanks,
:slight_smile: