Extension is greyed out

Description of the issue: Extension is greyed out + unable to access about/preference… click on either one = instant death

Steps to Reproduce (add as many as necessary): 1. 2. 3.

I was trying out this extension, and it borked the extension and preferences tab. “Downloads” and Task Manager dont seem to be affected.

The “faulty” extension isnt there when i checked out ~/Library/Application Support/BraveSoftware/Brave-Browser/Default/Extensions/. So im not sure whats going on… is there any way to force reset the extensions from the terminal?

Luckily (or surprisingly), i installed the same extension on real chromium browser and it didnt bork…

Actual Result (gifs and screenshots are welcome!):

Expected result:

Reproduces how often:

Operating System and Brave Version(See the About Brave page in the main menu):

Version 1.26.77 Chromium: 91.0.4472.164 (Official Build) (x86_64)

Additional Information:

1 Like

“Default” is the default profile:

~/Library/Application Support/BraveSoftware/Brave-Browser/Default/

Might you have another Brave Browser profile?

Also, does folder “cbnaodkpfinfiipjblikofhlhlcickei” exist, here:

/Users/user_shortname/Library/Application Support/BraveSoftware/Brave-Browser/cbnaodkpfinfiipjblikofhlhlcickei

If folder “cbnaodkpfinfiipjblikofhlhlcickei” exists, might you include here, a screenshot of its contents?

1 Like

Default is my only profile, and “cbnaodkpfinfiipjblikofhlhlcickei” is not found under Brave-Browser/

On the other hand, heres the output of the extension from chromium:

Is there any hack to force reset the browser/extension via terminal…?

Also just found out that New Window is disabled as well, im thinking just to nuke the entire browser and download from scratch…

Try make a new profile first, perhaps that will do.
This way you won’t lose / have to export and backup any existing bookmarks and other data, you can deal with those later.

edit: TL;DR
I just noticed you have Brave 1.26.77, current release is 1.28.105 and I could not reproduce the issue. I’d try updating if possible.
BTW, macOS here too, 10.11.6 .

Just to confirm, you also do not see the extension appear in Brave under brave://extensions?

Hmm i cant even open that up, like the whole browser is possessed somehow… “Bookmark manager” is disabled as well, heres the gif of it showing instant death…


Can you try creating a new browser profile and test to see if the issue persists in the new profile?

Not sure if it’s useful, I located a /Users/username/Library/Application Support/BraveSoftware/Brave-Browser/Profile 5/Extensions/cbnaodkpfinfiipjblikofhlhlcickei.


Yes, the issue persists with the new profile. Not sure if this has something to do with incognito mode…? Ive set it to default via this thread.


ive also tried to find ./Brave-Browser/ -type d -iname cbnaodkpfinfiipjblikofhlhlcickei but nothing pops up

I would definitely try switching back to standard windows to see if the issue is specific to launching in private by default.

Oh yes it does!
I just followed that procedure, and now I have those menu items disabled.
Let me see if I get the rest of the problems too…
edit: more or less. “Preferences” from the application menu gets me to about://blank .
edit: I removed the IncognitoModeAvailability, removed the extension, put back IncognitoModeAvailability and still have those menu items disabled.

cd ~/Library/Preferences
defaults delete com.brave.Browser IncognitoModeAvailability

ok yea, that seems to be the culprit…

defaults write com.brave.Browser IncognitoModeAvailability -integer 2

It would seem like “2” is forced to incognito only, and any pages destined to non-incognito mode (about/preferences/extensions/bookmarks/etc…) freak out and die because they dont know what to do.

-integer 1 would be for regular mode only, and incognito is disabled.

So im switching back to -integer 0

But it’s weird that ive set this up to 2 a long time ago and just bumped into this behavior…

Anyways, case closed! and thanks for all the help around this!

1 Like

Happy to know it’s solved.
I still wonder why those disabled items though.
No hint here: chromeenterprise.google/policies

edit: “New Tab” being disabled makes sense, now that I think… and the other ones too, being a policy it’s probably intended to prevent circumventing it.

more detailed docs at https://support.google.com/chrome/a/answer/9302896?hl=en

edit: open -a "Brave Browser" --args --incognito

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.