Export passwords not working?


Description of the issue:: cannot view or export passwords
How can this issue be reproduced?: brave://settings/passwords

  1. clicked on the three dots
  2. select export passwords
  3. provided my fingerprint (accepted by Windows)

Expected result:: a prompt asking where I want to save my file

Brave Version( check About Brave): 1.41.100

Additional Information: Same occurs when trying to copy or view a single password entry (I would expect the ***** to display the password or the clipboard to contain the password)

If must be missing something totally obvious!

What actually happens after you do this? Does it not save a file?

What exactly does happen? I know the way it works is usually you get to your passwords and you click the button to view. It then makes you sign in with the same authorization as your Windows login. As soon as you do this, the password can be seen.

If you’re saying it’s not working with your fingerprint, can you select Other Options and log in with your Pin or Password?

Btw, what version of Windows are you on? Also what type of device? (desktop, laptop, windows phone, tablet, or what?)

Thank you for your help.
I tried to sign with my Windows login, my PIN and my fingerprint.
After doing that nothing happens. The display does not change to display the password with the View. The Copy does not place the password in the keyboard. And the Export does not prompt for a filename.
I am using Windows 11 Pro, fully up-to-date.

Most of the things I’m able to help with are the basics and areas where issues have existed and been resolved. Your situation isn’t one I’ve encountered and I don’t want to suggest a million things that might waste your time. I’ll be researching later but in the meanwhile will tag to see if @JimB1, @Chocoholic, or @289wk might have any ideas on what’s going on and how to help.

Also want to advise it’s Friday night. I’m not sure if things are changing since they have some newer people helping here, but typically most of the Brave Support doesn’t work on the weekends. So if it seems to go unanswered over the next few days, that might be why. I’ll be saving this thread though and checking in, so we’ll get you an answer regardless, just might be a little while.

1 Like

@FrancoisK

@CerealLover will probably know the steps to take:

1 Like

Has this worked before?

Does the issue occur with any other browsers on the system?

Have you tried rebooting?

Hi

First, I suggest you install Firefox and import your bookmarks and logins as *.CSV; Keep the file in a safe place. You can import it to Brave in case there is a problem.

Second, try the following (in this order) and see if you can copy, export your passwords.

  1. Disable extensions
  2. Reset Flags at brave://flags/ (if you haven’t enabled or disabled features before).
  3. Login without fingerprint
  4. Reinstall (update) Brave from Release Channel 1.41.100 (Click on Download Brave Browser)
2 Likes

@CerealLover Brave is already updated to 1.41.100., I disabled Private Badger (only extension), no difference.
@JimB1 it was the first time I tried to export the passwords. And yes I did reboot, even using the same method to see the password as with the login (e.g. fingerprint/fingerprint or password/password).

Temporally disabling antivirus (ESET) made no difference.

On Firefox clicking on the “eye” icon displays the password. Interestingly (and someone concerning) it did not ask me to login before displaying the password.

More interestingly, and I suspect it may be the answer to the issue, it does not work in Edge, same behavior as Brave.
So in Edge, I disabled extensions, reset the flags, logged in without fingerprint, updated. Same result.

On an entirely unrelated laptop, Edge does show the password. Clearly something related to my laptop. Part of the reason I want to see the passwords is because I forgot one and it would be a pain to reset it…

Update (interesting I hope):

  • logged into the same laptop under a different rarely used account (no Windows Hello)
  • updated Edge and Brave
  • in both browsers there are no saved passwords
  • in both browsers, went to eBay.com and saved the login to the password list when prompted
  • rebooted
  • in both browser, I am prompted to enter my password to view
  • in Edge I see the password. In Brave I do NOT!

One more test: using the original login, Chrome has the same issue, I cannot see the only password saved.

Which brings me to a technical question: how is the password saving different in Firefox than the various Chrome variants? How is it associated to the Windows login?

I do realize it is not a unique Brave issue since the issue also occurs in Chrome and Edge.

Update: spent an hour on the phone with Microsoft Support. The issue is definitely related to the Windows 11 Profile: creating a new Profile solves it. Kind of because a) whatever password was saved is no longer on the list b) usual side effects of using another Profile. Finally Microsoft said “just reload Windows 11”…