Exception for hiding the referer header?

Description: We use JIRA Cloud at my place of employment. I received a new computer to replace my old one last week and can no longer access it, most likely due to a referrer header issue.

How to reproduce: When I go to our companies URL for login (which I cannot provide here), I can enter my login information, and then get this error message:

We couldn’t log you in. You may run into this issue when you use specific browsers or add-ons that hide the referer header for id.atlassian.com and other Atlassian sites. Check for these and then try logging in again.

I’ve looked all over the Brave browser settings but can’t find anything that would allow me to enter an exception for this. At this time I cannot access a critical system for my job.

Expected result: Ability to login

Brave Version( check About Brave): [
Version 1.16.72 Chromium: 86.0.4240.183 (Official Build) (x86_64)
]

Additional Information: Mac running Catalina 10.15.7

Hello @jfed

does turning the shield off help and if it did you tried to change the shield setting

hope that help and have a nice day

Could you please try Brave Nightly? We just merged a fix for Atlassian and would love to know whether it solves your problem.

1 Like

I have the exact same problem,
Version: 1.16.72 Chromium: 86.0.4240.183 (Official Build) (64-bit)

I have tried nightly, version 1.18.46 Chromium: 87.0.4280.49 (Official Build) nightly (64-bit)

The problem is NOT fixed. I have tried disabling shields and private mode without success.

@justsomeone1 turning the shield off doesn’t help.

@fmarier I downloaded Brave Nightly, and it crashes on launch. I have a crash report, but it says that because I’m a new user I can’t upload it. Its also too long to paste in here.

here is the top data in the crash file. I’m not sure if its helpful.

Process:               Brave Browser Nightly [46520]
Path:                  /Applications/Brave Browser Nightly.app/Contents/MacOS/Brave Browser Nightly
Identifier:            com.brave.Browser.nightly
Version:               87.1.18.49 (118.49)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           Brave Browser Nightly [46520]
User ID:               501

Date/Time:             2020-11-11 09:55:50.050 -0600
OS Version:            Mac OS X 10.15.7 (19H15)
Report Version:        12
Bridge OS Version:     4.6 (17P6610)
Anonymous UUID:        099A490D-29F9-3F7E-694D-AEAB618EA0C0

Sleep/Wake UUID:       BFCAAD63-75CE-4259-82BB-B064636829DC

Time Awake Since Boot: 93000 seconds
Time Since Wake:       6200 seconds

System Integrity Protection: enabled

Crashed Thread:        0  Dispatch queue: com.apple.main-thread

Exception Type:        EXC_BREAKPOINT (SIGTRAP)
Exception Codes:       0x0000000000000002, 0x0000000000000000
Exception Note:        EXC_CORPSE_NOTIFY

Termination Signal:    Trace/BPT trap: 5
Termination Reason:    Namespace SIGNAL, Code 0x5
Terminating Process:   exc handler [46520]

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   com.brave.Browser.nightly.framework	0x00000001095d9773 ChromeMain + 67043347
1   com.brave.Browser.nightly.framework	0x000000010570c07c ChromeMain + 1190172
2   com.brave.Browser.nightly.framework	0x00000001087c829b ChromeMain + 52292411
3   com.brave.Browser.nightly.framework	0x00000001055ec250 ChromeMain + 10992
4   com.brave.Browser.nightly.framework	0x0000000108701cc1 ChromeMain + 51479905
5   com.brave.Browser.nightly.framework	0x0000000108701bd4 ChromeMain + 51479668
6   com.brave.Browser.nightly.framework	0x0000000108700675 ChromeMain + 51474197
7   com.brave.Browser.nightly.framework	0x0000000108700d1c ChromeMain + 51475900
8   com.brave.Browser.nightly.framework	0x00000001055e9880 ChromeMain + 288
9   com.brave.Browser.nightly     	0x0000000103bc983f main + 287
10  libdyld.dylib                 	0x00007fff6ac08cc9 start + 1

Thread 1:
0   libsystem_pthread.dylib       	0x00007fff6ae08b68 start_wqthread + 0

Thread 2:: StackSamplingProfiler
0   libsystem_kernel.dylib        	0x00007fff6ad49dfa mach_msg_trap + 10
1   libsystem_kernel.dylib        	0x00007fff6ad4a170 mach_msg + 60
2   com.brave.Browser.nightly.framework	0x0000000108d23966 ChromeMain + 57909766
3   com.brave.Browser.nightly.framework	0x0000000108c85284 ChromeMain + 57260836
4   com.brave.Browser.nightly.framework	0x0000000108cd9ffa ChromeMain + 57608346
5   com.brave.Browser.nightly.framework	0x0000000108cacafe ChromeMain + 57422750
6   com.brave.Browser.nightly.framework	0x0000000108cf5f4a ChromeMain + 57722858
7   com.brave.Browser.nightly.framework	0x0000000108d14233 ChromeMain + 57846483
8   libsystem_pthread.dylib       	0x00007fff6ae0d109 _pthread_start + 148
9   libsystem_pthread.dylib       	0x00007fff6ae08b8b thread_start + 15

Thread 3:
0   libsystem_pthread.dylib       	0x00007fff6ae08b68 start_wqthread + 0

Thread 4:
0   libsystem_pthread.dylib       	0x00007fff6ae08b68 start_wqthread + 0

Thread 5:
0   libsystem_pthread.dylib       	0x00007fff6ae08b68 start_wqthread + 0

Thread 0 crashed with X86 Thread State (64-bit):
  rax: 0x0000000000000000  rbx: 0x00007ffeec037660  rcx: 0x00000000000003e6  rdx: 0x00000000000b3c60
  rdi: 0x00007ffeec037580  rsi: 0x00007ffeec037520  rbp: 0x00007ffeec0375e0  rsp: 0x00007ffeec0375e0
   r8: 0x0000000000004c3f   r9: 0x0000000000000034  r10: 0x00007fe6ece00000  r11: 0x0000000000000000
  r12: 0x00007ffeec037660  r13: 0x00007ffeec037788  r14: 0x0000000000000000  r15: 0xaaaaaaaaaaaaaaaa
  rip: 0x00000001095d9773  rfl: 0x0000000000000246  cr2: 0x00000001095d9760
  
Logical CPU:     0
Error Code:      0x00000000
Trap Number:     3

try to DM fmarier with it click on his name then message

and hope they fix it soon and have a nice day all of you

@justsomeone1 thanks! that worked and I was able to send @fmarier the whole log file.

you very welcome @jfed

Thanks. I’ve passed the info on to my colleagues. Hopefully this will be resolved soon.

I assume the crash happens every time you try to open Nightly?

yup. Tried several times. Crashes immediately.

Edit: Its letting me upload logs now. See attached.Brave Browser Nightly_2020-11-11-095611_Jasons-MacBook-Pro copy.txt (81.0 KB)

as of this morning, it’s working. @fmarier Thanks for your help and getting the fix in so quickly!

Excellent. After checking with my colleagues they pointed out to a crash that was introduced by mistake in Nightly.

Just to confirm, the Atlassian problems you were running into are resolved in Nightly?

I’m actually not sure if Nightly is working on my machine or not. Atlassian now works in Brave LTS.

Which version of Brave did you get it working in? (you could copy here the first three lines of brave://version)

Brave 1.16.72 Chromium: 86.0.4240.183 (Official Build) (x86_64)
Revision 0b568b034b8f7994697cb341eeca5979b84151cc-refs/branch-heads/4240@{#1374}
OS macOS Version 10.15.7 (Build 19H15)
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.