Excel Files don't download


Description of the issue:
Trying to download an XL file from any site opens a blank page. The file does not get downloaded. Shields up or down makes no difference.

How can this issue be reproduced?

  1. Go to a site that has XL files for downloaded.
  2. Try and download the file.
  3. Only a blank page will open instead the save dialog box.

Expected result:

The file to be downloaded to my computer so I can use it.

Brave Version( check About Brave):

Version 1.42.97 Chromium: 104.0.5112.102 (Official Build) (64-bit)

Additional Information:

This is the only type of file that will not download.

Hi

Try installing XLS extension or MS EXCEL app.
Open Windows Settings, Click on Apps and check if excel is the default app for .xls files.

@BobD Also, can you verify, do you have Ask where to save each file before downloading enabled in brave://settings/downloads?

Also, if you were to Create a new profile from your Settings in Brave, them try to download, would it work or do you have the same issue?

Lastly, what website are you trying to get from? Can you link to anything by chance? I’d like to test it myself. When I’ve downloaded Excel sheets, it’s gone with no issues.

Saoiray, Using a new profile didn’t work either. I got a blank page but this one said ‘Couldn’t load profile’. I do have ask for download checked.

I tried using a different computer also and it still didn’t work

1 public site that has a .csv file, which also doesn’t download, is https://www.realtor.com/research/data/. Click on any of the links

Yeah, so it works for me.

I went to the site:

Did a left click on one of the Excel links, where it opened the download thing.

Proceeded to download it

Realtor.com Real Estate Data and Market Trends for Download - Brave 8_28_2022 11_12_48 AM

And was able to open

So it does loop back around to having to figure out what’s going on with your device/browser in particular. At least showing seems to work as intended on other devices and it doesn’t seem to be an issue with the link or site. (I did try with other links too)

If the issue continued in New Private Window, then it suggests it’s not settings or extensions. The next thing I believe people usually look at would be something like an antivirus or firewall, especially if you’re using something like Avast…as it can sometimes block things. Don’t think having you do anything like clear cookies or anything would help.

We’re getting into areas where I kind of just have to toy with settings and random things until can figure it out, which gets time consuming. I’m more the triage and common sense person, where I help based on what others have dealt with or have seen where people have resolved similar issues. Once start having to think more technical or “outside the box,” usually need to have the smarter people like @CerealLover, @JimB1, or even @Chocoholic pop in and have solutions. They usually are awesome and usually do well in either solving an issue or at least guiding in a direction that helps in finding the solution if they can’t find it themselves.

Feel bad saying all that and have a feeling the solution is going to be something simple, but it’s just not coming to the forefront of my mind right now.

That wouldn’t solve where the problem initiates, would it? From what I’m reading, they are saying can’t even download. Yours is more for trying to open a file, right? Compared to clicking to download and not getting the Save As box to appear:

Think he’s saying instead of image above, is getting just a blank page and no way to download.

Just wanted to ask and clarify.

Sorry, don’t have any specific suggestions. Tested and working for me too.

Just to clarify, you are able to download other types of files? I would think no file types would download in this situation. I find it strange it would only impact excel and csv files. Can you confirm you are able to download other file types with no problem?

I want to make sure I am understanding this too. Are you receiving the save dialog box but there is just a blank pop-up? Or does clicking a file to download open a blank NTP? No error messages in either case? Can you provide a screenshot?

The above makes me think something else may be impacting. Router? Anti-virus software used on both computers? Have you checked to see if you can download files using a different browser? Have you tried closing all instances of Brave then right clicking the Brave icon on your desktop and running Troubleshoot compatibility? I would do this for both computers.

image

Finally, can you try changing your download location at brave://settings/downloads and see if that works. I don’t think this is the issue since the same thing is happening on two different computers and thus two different installations of Brave. Just curious. :slightly_smiling_face:

You might want to try downloading Beta and/or Nightly and see if the problem occurs in those versions, especially if you can download using other browsers.

Hi

Try

  1. Right-clicking on the .csv or xls link then choose “Save link as”. What does it give?

if issue persists,

Open brave://settings/help, click on Version, download Brave and reintall it.
Open brave://settings/help and click on relaunch

My problem is it’s not even asking me where to download it so I can’t save it. Once it’s saved I will be able to open it because it will be on my computer

I’m not even getting the save as box, just a blank page. Yes I can download and save other types of files that are non XL. I have to use Chrome to download XL files. I don’t have any other instances of Brave open. I have the same anti-virus on both computers

What anti-virus are you using? Several issues recently with Avast, including problems with features using downloads, that I think should have been fixed. However, might want to try disabling your anti-virus software and see if that makes a difference. If it is your anti-virus, you probably will have to get support from the provider unless you know the program well enough to troubleshoot yourself.

You could try clearing history/cache for all time and rebooting your system. May be just a glitch with your anti-virus that will clear itself. Although would be odd for the same problem to occur on both computers unless you computers are on same network and it is something with anti-virus/network settings… dunno, getting way over my head here.

Otherwise, just work through some of the other troubleshooting steps. I would try testing with at least the Beta version.

Can you right click anywhere on the page and select inspect? Are there any error messages? Screenshot would be helpful if there are.

Please post an update.

Can you show us a screenshot of this?

Also, did we ever get insight into whether or not the issue occurs in a Private window? And whether you have any extensions installed (and if so, which ones)?

Recognizing that a new profile should have accomplished the same thing, considering the above, I’m wondering what’s going on with the ‘profile’ situation there.

Also, exactly what antivirus software (or any other security software) are you using?

Is this Windows 10, or another version?

1 Like

I discovered the problem. When I migrated to Brave from Chrome an extension called ‘Office Editing for Docs, Sheets & Slides’ migrated also and was turned on. I turned it off and now I can download and save XL files. I assume it will also affect any MS office file as I didn’t try to download any other type.

It was off in Chrome also.

Thanks everyone for all your help

2 Likes

What’s weird is when you create a new profile in Brave, it doesn’t come with extensions. So when you said you created a new profile and used there, that extension shouldn’t have been there. So that’s a bit weird for me.

Glad to hear it

1 Like

I don’t know. There were no extensions in the test profile but when I went to it just now the ‘save as’ box came up so I guess it affects any profile whether or not the extension shows up.

You may want to check the origin and legitimacy of that extension. As far as I know, an extension should be constrained to the profile in which it is installed, unless it requests ‘special’ permissions – such as (but not necessarily limited to, I’m not sure TBH) Access the page debugger backend for example.

And I can’t see legit Google extensions requesting that level of permissions. I’m probably wrong, but something you should double-check – make sure the extension doesn’t have strange permissions granted to it. You should be able to see its permissions in the extension’s details page.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.