eToro.com: login page doesn't load

Description of the issue:

When loading the login page for the first time, it doesn’t load, it just sits loading forever.

If you reload the page, the issue goes away.

To replicate, clear all browsing history and data for etoro.com, close the browser, visit the URL in question and observe that the login page never loads.

Exact URL of the website in question:

https://www.etoro.com/login

Screenshot of the ad as it appears in Brave

Did the issue present with default Shields settings? (yes/no)

No

Does the site function as expected when Shields are turned off?

Yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):

Yes. Aggressive blocking of ads, cross site cookies blocking, strict fingerprint blocking.

Does the site work as expected when using Chrome?

Yes

Brave version (check About Brave):

Version 1.20.108 Chromium: 88.0.4324.182 (Official Build) (arm64)

Hi, Try Disabling Strict fingerprint blocking and are there any filters enabled in brave://adblock ? @Gigabit

@fanboynz disabling strict fingerprint blocking made no difference.

There are no filters enabled there.

Same problem on https://www.talktalk.co.uk/shop/ - just sits there loading forever.

I can replicate this, I’ll look into it.

Should fix the loading. Something like this is site-specific (so not all slow loading/no loading are the same)

@fanboynz Do you have any ideas for eToro?

The only issue I saw was related to Fanboy Social/Annoyances. which I fixed

@fanboynz The fix has not worked, TalkTalk still does not load.

Takes 24-48hrs for the update to roll out. I’ll re-check Friday (NZT) to confirm.

@fanboynz on https://new.talktalk.co.uk/, navbar is broken when using any filtering and fingerprinting.

@fanboynz Looks like the old TalkTalk site is working correctly now, many thanks.

Navbar on new.talktalk.co.uk is still broken.

Works for me, I was able to browse via the navbar without issue, in Brave release/Beta

If you scroll the page, the navbar does not stick to the top as it should. Please re-try.

(Top, Default) (Bottom, with Fanboy Annoyances enabled) Regarding the space at the top, not all blank spaces left over can be collapsed.

Hi @fanboynz, AdGuard has the cookies policy and gap properly blocked:

See the rules below:

new.talktalk.co.uk#%#//scriptlet('set-cookie', 'TT_GDPR', 'true')
new.talktalk.co.uk#%#//scriptlet('set-cookie', 'TT_GDPR', 'true')
~travelchannel.co.uk##.cookie-wrapper
##.cookie-policy:not(body):not(html)

No snippet support in Easylist Cookie/Annoyances. Brave-adblock only implements uBO rules, set-cookie is a Adguard specific rule and not available in uBO (btw, set() isn’t the same).

Not much can be done here sorry.

@fanboynz In that case can we remove the rule to block the cookies banner as this breaks the navbar when you scroll?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.