Error uploading image on Twitter


Description of the issue:

As described in this post, I’m having the exact same issue, except on Brave 1.0 (release) (Windows x64 desktop). Same error message, same exact results. Works fine in other browsers. Does not work in Brave, regardless of any settings.

How can this issue be reproduced?

  1. Upload the attached image to Twitter, via twitter.com, on Windows 10 Pro 64-bit (version 1909 OS Build 18363.476), using the Brave 1.0 desktop browser.
  2. Witness the error message: image

Expected result:

Successfully uploading an image on Twitter.

Brave Version( check About Brave):

Version 1.0.0 Chromium: 78.0.3904.97 (Official Build) (64-bit)

Additional Information:

I am including the image here, but I am worried that Discourse may have resized/rewritten the bits. Let me know how I can send the actual original image for you to test with.

The image:

Hi @ChesterCheeser,

Thanks a bunch for writing in a reporting. Does the image upload successfully with Shields down?

The thread I linked above had a final post that went unanswered:

However, I am experiencing it now on Brave 1.0.1 desktop, and it’s reproducible every time. (No image is successfully uploaded on Twitter.)

@ChesterCheeser,
Can you tell me what your Shields settings are set to for Twitter?
Can you confirm that no image works – rather than just that specific image?
If you try to do this from a Private browsing session, do you get the same result?

@Mattches Sheilds is off for Twitter in normal browsing.

In Private browsing, I was able to post a different image.

I’ll do some more trial-and-error in normal browsing to see if I can better narrow the cause for you.

@ChesterCheeser,
I think if you clear your cache/site data for Twitter you should be able to post. Either that, or there’s an extension you have installed that’s complicating matters. Can you try clearing data for Twitter and seeing if that helps?