Error on yesterday's update [Windows "blank window" issue]

Yesterday I was notified through the browser that an update was available. I selected the update option and the update began, but unfortunately I didn’t get a screenshot when it told me that the update hadn’t been able to finish. The current link turned black and gray and another orange and white icon appeared. I continued to use the gray because I was working. This morning (still working) I attempted the other icon and got only a blank screen. No tabs, no top bar, just blank.

I read through other topics on this forum and found one that indicated to try renaming the “old” Brave folder in appsdata. I did so, but it just made both of them act up. I attempted to reload Brave from but no effect. Same problem, and now the old Brave icon doesn’t work. I’m currently working from Chrome because I can’t access ANYTHING in Brave. Except that Chrome doesn’t have the links I need for my work…

I attempted to uninstalll Brave, was able to Uninstall the old version but not the new version. It just sits there and won’t let me either attempt to open the browser or uninstall. I’ve shut down the computer, which did nothing.

I am running on Windows 7 PC, Dell Studio. I don’t have my current “Brave” version number because I can’t get in to check.


Please let me know if you need more information.


Anyone? Please? I LIKE Brave, and I’d like to continue using it. If I can’t fix this problem, it’s essentially dead.


Yea, I have the same problem as you. The worst part is that I can’t uninstall the new version (0.57). I really really don’t like having non working software on my machine, which also fails to uninstall itself.

This is not good enough, Brave developers :confused:


Can you add any information to what I entered above? Your operating system? Process you’ve gone through to get here? Anything to help them troubleshoot when they get around to this issue? Seems to me that full failure of the system is a mighty big hole.

1 Like

I tried physically deleting all the Brave folders, and it still does the same thing. I guess I’m stuck with Chrome until someone can get to this. I wish I hadn’t deleted the old Brave install file–at least I could go backward, then.

If nothing else, PLEASE tell me how to uninstall the updates!

1 Like

I’m on windows 7 and the ‘old’ version 0.26 is still working if I omit starting the debugger when it crashes on startup |o|… I did not try to uninstall the ‘old’ version.

I got here like you described after the update, I got the message telling me I should download the new version. I downloaded the 64 bit version, but it installed under x86 |o|… Yea and when starting the new version it just shows that blank window and stalls.

I hope they provide a tool to remove this crap…


OK, I found something that might help–the debug file for the update.

2018-12-07T23:05:23.041Z - Creating “Brave (old)” shortcut on desktop
2018-12-07T23:05:24.150Z - Attempting silent install using “C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe”
2018-12-07T23:05:50.773Z - Creating “Brave (old)” shortcut on desktop
2018-12-07T23:05:51.327Z - Attempting silent install using “C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe”
2018-12-07T23:05:54.642Z - Error thrown when installing brave-core: Error: Command failed: C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe /silent /install

2018-12-07T23:06:02.798Z - Creating “Brave (old)” shortcut on desktop
2018-12-07T23:06:04.318Z - Attempting silent install using “C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe”
2018-12-07T23:06:32.875Z - Error thrown when installing brave-core: Error: Command failed: C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe /silent /install

2018-12-07T23:06:52.768Z - Error thrown when installing brave-core: Error: Command failed: C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe /silent /install

2018-12-08T03:34:53.775Z - Creating “Brave (old)” shortcut on desktop
2018-12-08T03:34:56.083Z - Attempting silent install using “C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe”
2018-12-08T03:35:02.103Z - Creating “Brave (old)” shortcut on desktop
2018-12-08T03:35:02.602Z - Attempting silent install using “C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe”
2018-12-08T03:35:24.484Z - Error thrown when installing brave-core: Error: Command failed: C:\Users\User\AppData\Local\Brave\app-0.26.0\resources\BraveBrowserSetup64.exe /silent /install

2018-12-08T03:35:58.797Z - brave-core already installed at “C:\Users\User\AppData\Local\BraveSoftware\Brave-Browser\Application”
2018-12-08T03:35:58.797Z - Launching brave-core at “C:\Users\User\AppData\Local\BraveSoftware\Brave-Browser\Application/brave.exe” with “–upgrade-from-muon” flag


This is something I haven’t seen so far so I’m not entirely sure what may be causing it. However, I do know what I think will fix it but I’m a little confused about your report.

You mentioned that

This is…strange. By what method did you try to uninstall Brave-Core (new)? In Win7, you should be able to uninstall it the way you would any other application. Navigate to Add/Remove programs in Windows, find Brave Browser and uninstall. If this is what you tried and it didn’t work, can you describe to me what happened during the attempt?

You also mention that you did uninstall the Brave Muon (old) build on your machine. When you did, a box should have appeared asking if you’d like to remove user/browsing data as well? Did you check that box or no (definitely don’t).

If you can answer the above questions I think we can get this issue resolved with your bookmarks/saved data intact.

I apologize again for the late response and I truly appreciate your patience.

1 Like

I went to add/remove programs, selected Brave, and selected uninstall. Nothing happened, so I went to the old program, which uninstalled without a problem. As you can see from the picture, Uninstall Brave is running but an hour from now it will still be running and nothing will have happened.

When I uninstalled the old one, no box appeared. The program just disappeared from the list.

(Edit note: Two hours later I finally shut it down)

1 Like

This new image shows the Brave services open, but Uninstall is not one of them.

1 Like

I logged an issue, which has similar log entry:

Error thrown when installing brave-core: Error: Command failed: C:\Users\Test\AppData\Local\BraveBeta\app-0.25.217\resources\BraveBrowserSetup64.exe /silent /install

Maybe they are related.

1 Like

@Lauren, apologies for the late response. I’m looking into this right now - haven’t seen this happen before. Will return with more information.

The blank screen browser seems to be getting lost under the uninstall issue. Please remember to address both.

If we solve the uninstall issue, it’s likely the blank screen will go away as well.
Here’s what I would try,

  1. Reboot the computer and confirm that you’re the admin of your machine and do any install/uninstalling with elevated privileges (“run as admin”).
  2. Kill all Brave processes before attempting to uninstall. The image you last shared shows Brave services running - kill them.
  3. Try again to run the uninstaller again, then reinstall.
  4. If that doesn’t work, have you tried just running the installer again (this one here)?

Rebooted. I am running as the administrator as far as I know, with access to change all accounts on this computer. All Brave processes killed (none active after rebooting) but it still won’t uninstall. Same result as before.

I deleted the old install files (third time) and downloaded from the link provided but still got only a blank screen after installing.

I also attempted the uninstall from another profile on the computer, but when I selected Brave and chose Uninstall it said the program had already been uninstalled. Same behavior when I downloaded and loaded from that profile, though. Blank screen, and now it won’t uninstall from that profile.

Well this is not ideal, is it?
Again, apologies for the inconvenience. I’m going to see if I can rope some devs in on this because I’m not entirely sure what the issue is other than the fact that you’re using a Win7 machine.
I’ve seen a couple other users reporting this behavior and they’re using Win7 as well so there’s likely a connection.
Going digging, appreciate your patience!

@Mattches Same result when running Brave install with “Run as Administrator”

@Mattches I think I’m going to do a restore to before the 7th, then try a new install. I’ll let you know what happens.

(Edit note: Or not. Looks like Windows did a “critical” update on 12/10 and deleted all previous restore points.)

1 Like

It was working but the blank screen have returned today. Something went wrong with the new update. I hope the devs will fix this issue :slight_smile:

Returned? Had you been getting the blank screen before?
What OS are you using?