Error message on free token application


#1
Brave 0.22.721
V8 6.6.346.32
rev bfe7cdd
Muon 6.0.12
OS Release 4.4.0-21-generic
Update Channel Release
OS Architecture x64
OS Platform Linux
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 66.0.3359.170

hi, in Settings > Payments, if I click on ‘claim my free tokens’ I get error message “Uh oh. The Brave Payments server is not responding. Please try again later to claim your token grant.
Note: This error could also be caused by a network connection problem.”

Over th elast two days it’s been the same. Please advise.
Thanks
Andy


#2

Hi @clickforafrica,

First, maybe you reached maximal attempts. Please wait for ~24 hours (or less) before you try again.
Second, did you behind a VPN? If so, please try to disable it when you claim the grants.

Thanks,
:slight_smile:


#4

eljuno thanks for replying. At least now I know there is something wrong! I’ll check what I can. I have always got the error message, no VPN. I’ll try a couple of different browsrs. I can’t log in to uphold on brave, but can in chrome. Maybe it will work ok - will report back. Cheers
[/quote]


#5

For Uphold, I think you need to Allow ads and trackers via Brave icon at top right as a workaround. It’s per site shields settings and will not affect other sites.

:slight_smile:


#6

oh yes you’re probably right - still getting used to this. I still cant figure what the problem is with the error message on claiming though, I forgot I cant use a different browser for that.

Does Brave keep a log somewhere, maybe if I post that?
thanks


#7

Please update to latest build, 0.22.810.

Then, if you still see this issue, please wait a bit to try again (several hours) as we have some rate-limiting (i.e. number of allowed attempts) to combat fraud.

Thanks,
Lauren


#8

Not seeing the version posted. Somehow I missed it. :laughing:


#9

haha no worries @eljuno :smiley:


#10

ok, thanks. Can I just do sudo apt update brave or will I need to go through the whole install again? This is all a bit new to me still.


#11

Hi @clickforafrica

In regards to updating on Linux, it was suggested to me that you first sudo apt-get update and then sudo apt-get upgrade

Best,
Lauren


#12

0.22.721 still - I did update and then upgrade, and Brave was in there while it was doing its stuff. Is 810 maybe on a different place, like for testing or something? I rebooted, still the same. I used apt-get to download originally a few days ago so it should be the same repo?
Thanks


#13

I checked, and I did it correctly according to the instructions on github for linux mint… it all seems ok, I ran sudo apt-get update && sudo apt-get upgrade -y again and it returned 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. so it’s all up to date. but

Brave 0.22.721
V8 6.6.346.32
rev bfe7cdd
Muon 6.0.12
OS Release 4.4.0-21-generic
Update Channel Release
OS Architecture x64
OS Platform Linux
Node.js 7.9.0
Brave Sync v1.4.2
libchromiumcontent 66.0.3359.170

I like how the forum preserves the formatting!


#14

It’s still not working today. As far as apt-get is concerned I am on the latest available version. Is there any kind of log I could find and post here that might shed some light?
Thanks
Andy


#15

@sriram any idea why the Linux install isn’t updating?


#16

@clickforafrica Did you install the app via snap or via deb? If its via snap its still 0.22.721 is the latest build available via snap.


#17

sriram
snap sounds familiar, yes I probably did use that. Specially considering it won’t update beyond 721, that would be a big coincidence!

Still, was this a known issue with 721? Or could I try other things to find out what’s wrong? It has not worked at all for me, since ?I started.
Cheers
Andy


#18

It’s not an issue with 0.22.721, AFAIK. Its simply because that version is not supported to claim the grant. You should use the latest version (at least 0.22.727) to claim your free BAT. https://brave.com/brave-users-get-rewarded-to-browse/


#19

Thank you all, it’s a lot clearer now. Any idea of when the snap update will be available, or where I could find out?
[edit] it’s available now, installed and working. All ok so far.


#20

snap updates are not under our control. But glad that its working for you now. Will close the thread for now. Do open a new thread if you face any other issues


#21