Error code 3: 0x800700C1 -- system level

Description of the issue:
Every now and then I get this issue where I cannot update Brave.
I’m using Windows 10 with Brave version 0.70.121 and getting the error “error code 3: 0x800700C1 – system level”.
I’ve tried reinstalling the browser, but no fix.
I tried a previously mentioned troubleshooting step that had me add a BraveUpdate.ini file to my C drive.
It returned a log and in it it has -

[11/19/19 15:32:35.401][BraveUpdate:goopdate][18520:6580][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /medsvc]
[11/19/19 15:32:35.410][BraveUpdate:goopdate][18520:6580][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[11/19/19 15:32:35.410][BraveUpdate:goopdate][18520:6580][is machine: 1]
[11/19/19 15:32:35.415][BraveUpdate:goopdate][18520:6580][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[11/19/19 15:32:35.465][BraveUpdate:goopdate][12060:20312][DllEntry][“C:\Program Files (x86)\BraveSoftware\Update\BraveUpdate.exe” /svc]
[11/19/19 15:32:35.475][BraveUpdate:goopdate][12060:20312][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0\goopdate.dll][version 1.3.99.0][opt][dev]
[11/19/19 15:32:35.475][BraveUpdate:goopdate][12060:20312][is machine: 1]
[11/19/19 15:32:35.481][BraveUpdate:goopdate][12060:20312][Current dir][C:\Program Files (x86)\BraveSoftware\Update\1.3.99.0]
[11/19/19 15:32:35.512][BraveUpdate:goopdate][12060:20312][DllEntry exit][0x00000000]
[11/19/19 15:32:35.512][BraveUpdate:goopdate][18520:6580][DllEntry exit][0x00000000]

Any help would be greatly appreciated.
Thank you

I’m using Windows 10 with Brave version 0.70.121…

Try updating to the latest version? Not much can be done really except just manually updating though… Chrome used to give me this kind of headache…

That’s the issue. I can’t

How would I perform a manual update?

Yeah, Chrome used to do it to me too :frowning: #Chromiumlyf

Download the brave installer and install over your current install… Or uninstall brave first, then install brave…

Oh right. Already tried that multiple times.
Thanks for your help though.

Hopefully someone can get to the bottom of this.