Error 400 on Google Calendar (Gmail seems fine)

Description of the issue:
I’m getting error 400 when trying to get in to Google Calendar. (Screenshot attached)
Here is what I already tried:

  • Restart browser and computer.
  • Removed Brave Shields
  • Allow Google login for extensions in ON
  • Tried to get thru a Private Window

How can this issue be reproduced?

  1. Go to : https://calendar.google.com/

Expected result:
I should see Google Calendar

Brave Version( check About Brave):
Version 1.42.65 Chromium: 103.0.5060.114 (Official Build) beta (x86_64)

Additional Information:
With Chrome it works fine

I would start by updating Brave to the latest release.

After that, do you have any extensions enabled? (If it happens in a Private window as well then it’s unlikely to be an extension, but not impossible.)

Are you using Secure DNS in Settings?

Are you behind a proxy?

Is any antivirus or other security software (besides MS Defender) installed? If so, does anything change if you temporarily disable it?

Thanks @JimB1 - I tried removing all extension but still it is error 400.
I updated to the latest release.
No proxy or DNS
I use a mac - so no anti virus or security software.
Really weird problem.

Ya, weird indeed.

Have you tried in a new profile? (Make sure your original profile does not have any open windows; only the new profile should be open.)

Create a new profile

If the new profile also has issues, I would maybe suggest using the Network console in DevTools to see where the 400 is actually coming from; F12, then go to the Network tab, make sure the red dot at the left edge is enabled (to record network logs), and also that the ‘Preserve log’ box is checked. Then try loading the page and pick out the details for the log entry that results in the 400 ‘status’ value. Maybe something will jump out at you as a clue to the problem, or you can share it here and see if we can help spot anything.

1 Like