Entering asterisk * into allowed cookies cannot be deleted and shuts off Brave Shields


Description of the issue:

Version 1.40.113 Chromium: 103.0.5060.114 (Official Build) (64-bit)

I think it was about a week ago when I entered an asterisk, which is this symbol * into ‘Sites that can always use cookies’ i.e. the allowed cookies, for a website.
|
Since then, the asterisk has stayed within allowed cookies. I knew the * was there and I decided to delete the setting since I don’t need it anymore.
|
I put it off and have now forgotten what the * was for, but I tried deleting the * from allowed cookies tonight and found that it won’t leave.
|
If I click Remove then my cookies settings will change from ‘Disable all cookies’ to ‘Disable third-party cookies’. If I click Block, nothing happens. If I click Edit and delete the asterisk, I cannot Save that as a cookie setting. It’s just an empty field. If I click Edit and then change the allowed cookie setting to another website, any website, it could even be a single letter, that will also be allowed in allowed cookies, but the asterisk is still there. (That single letter or website can be deleted as usual. It’s just the * that remains.)
|
I’m not sure about this part since I only just tried getting rid of * tonight and when it wouldn’t, then I really started paying attention - It seems that everywhere I go online, Brave Shields is OFF. These are websites I have never been to. I do not block Brave Shields on many websites since I always keep Brave Shields ON. There are very few specific websites I have turned Brave Shields OFF for. Therefore, I wouldn’t know if those would be effected since I don’t have many of them anyways. I am not sure if this asterisk in allowed cookies and Brave Shields staying OFF are related since I only started paying attention tonight. (see end of post for additional information.)
|
Clicking ‘Clear on site close’ does nothing. I clear all cookies (except for ‘Site and shields settings’) on Advanced and on ‘On exit’ and it also does nothing. I clear Basic and nothing. I close the browser down, restart it, nothing, I close the browser down and restart the computer, shut the computer down, turn the computer on, open Brave, nothing.
How can this issue be reproduced?

  1. Open Brave.
  2. Go into ‘Privacy and security’ → ‘Site and shields settings’ → ‘Cookies and site data’ → ’ Sites that can always use cookies’ → Click Add
  3. Add the asterisk symbol, which is *

Expected result:
The asterisk cannot be removed from allowed cookies and Brave Shields will be automatically turned OFF everywhere.
Brave Version( check About Brave):

Version 1.40.113 Chromium: 103.0.5060.114 (Official Build) (64-bit)

Additional Information:
In allowed cookies, there is no garbage can symbol next to the * nor the arrow that is next to each site indicating where you can go to look at their specific settings. It’s literally an * asterisk symbol with the three dots in a vertical line like this . . . but vertical, which is what I can click for Block ‘Clear on site close’ Edit Remove to pop up.
|
Additionally, the asterisk * is only allowed (and won’t leave) in Brave right now on my work computer. Brave browser on my work computer is the only one having this problem with Brave Shields and the asterisk. My cellphone and my personal computer, which I haven’t used in a while so I didn’t realize, both have Brave browser installed but neither of them has the * nor any problems with Brave Shields.

1 Like

@yuttych

In a Brave Browser > New Window, go to: brave://prefs-internals/

Search for this exact string: "braveShields": {

DO NOT attempt to edit anything in that window.

Please take a screenshot of that area, all around the lone asterisk entry (that you will see) and a few more lines up and down (such as you see in my screenshot). Your screenshot may look like:

Screen Shot 2022-07-12 at 5.18.44 AM

. . . and then close the window.

Please supply us with that screenshot, here. Thanks.

1 Like

1…
I opened up my browser to come here to check for any activity on my post and Brave Shields was working again when I came here. I went to a different website on ‘public’ browsing, then a different website on private browsing, and Brave Shields is working on both. I went into cookies and the asterisk * is gone. Everything is back to how it was. I don’t know what happened.
|
The only thing I can think of is last night I clicked on the Brave Shields lion icon and then clicked ‘Global defaults’ in the popup menu because that only seems to show up when Brave Shields is turned OFF. I was taken to a settings page for Shields. I clicked on ‘Block cookies’ which was set to Disabled and I selected All.
|
I went back to the allowed cookies page and my cookies were changed from ‘Block all cookies (not recommended)’ to ‘Block third-party cookies’. The asterisk was still there. I went back to the Shields page by clicking ‘Global defaults’, and it was either still on All or it reverted to Disabled, but I can’t remember. I also can’t remember if I changed back to ‘Block all cookies (not recommended)’ before OR after I went back to the Shields page, but I did change it back at some point. I did not leave it, and I did not change anything else in settings.
|
Then I closed the private browsing windows until only the settings page was up, ‘More tools’, ‘Clear browsing data…’ and closed that page when it was done.
|
Other than this, I stayed off browsing here on my work computer for about the past two-three days. I have not tried updating Brave, I’ve only restarted/updated my computer multiple times to solve a separate issue. It had nothing to do with Brave.
2…
I still followed the steps. Maybe it can still be helpful. I took two screenshots to give multiple “strings”. (i don’t know how to organize them so i hope they load and are sorted right)